What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

For some time now I am not seeing user avatars in IE8, but only the red-x no-image indicator. This is actually occurring to me on all stack exchange sites. Is there some setting I am unaware of?

Btw, I am able to see user avatars on FF. And I do not have images turned off in IE, either.

Not sure if this is a meta-SO question or a SuperUser question, but here I am.

share|improve this question
2  
What do you get if you visit gravatar.com on IE8 (that's the website where the avatars are hosted)? Have you tried clearing your browser (IE's) cache? –  Matt Sep 25 '12 at 22:35
    
When I visit gravatar.com everything is nominal. No problem. Clearing the browser's cache changes nothing. –  Cyberherbalist Sep 25 '12 at 23:20
3  
Seeing gravatars is now a 5000+ rep feature only (:P) –  Richard JP Le Guen Sep 25 '12 at 23:28
    
Ha. That was slightly amusing. –  Cyberherbalist Sep 25 '12 at 23:29

1 Answer 1

The problem is likely due to a security policy issue in IE: The page is an http URL but some (actually many) avatars are https URLs.

Example:

The page of (a random) user - a non-secure http URL

This user has this avatar image (at least at the time I'm writing this) - a secure https URL

On Firefox (and others) the page and the avatar image look fine. On IE - or maybe on SOME IEs, depending on the security settings - the avatar is a broken image because IE won't load the https-source into the non-secure page.

I have the same issue in IE 11, and since I hardly ever use IE my (browser security) settings are the default as Microsoft chose them.

UPDATE:

It seems my first guess was wrong - but maybe not entirely, so I'll leave it here.

The real problem seems to be IE Tracking Protection. For some reason downloads form gravatar are blocked, in the console you find message "SEC7114" (link to a Microsoft explanation). When I disable tracking protection in IE the gravatar image loads just fine.

When you go to

C:\Users\[[USER]]\AppData\Local\Microsoft\Internet Explorer\Tracking Protection

you'll find (text) files with the tracking protection data used by IE. In one of those files you'll find a line that

-d gravatar.com

More details about IE Tracking Protection lists can be found here. Use notepad++ or some other editor than standard MS Windows notepad.exe though, those files have Unix line endings!

Here is the Microsoft page where IE users can install tracking lists from. It is likely that it depends on which tracking lists are actually installed and enabled. I have found that gravatar is in at least one list that I installed, the one from abine.com (link to the text list).

I also found this Meta-Stackoverflow issue: "Is Gravatar a privacy risk?".

share|improve this answer
    
Recent changes in Firefox affecting the handling of mixed content has made a lot of this type of issue pop up in systems I work on, this is probably the correct assessment. –  Chris Dec 5 '13 at 0:00
    
@Chris - I've updated my answer, it seems it's the tracking protection and not a general security setting is to blame. –  John Smith Dec 5 '13 at 11:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .