Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I was trying to run a query in Data Explorer without logging in (I didn't notice that I am not logged in). When I click on Run Query button, I got a Captcha to avoid spam queries. But what I found that there is a Textbox instead of a Button for I'm a Human Being.

enter image description here

The Textbox is not ideal option for that. So there should be a button instead of Textbox like this one:

enter image description here

share|improve this question
Whatever, robot. – Won't Oct 4 '12 at 16:44
Is that actually a textbox, or is it a button that just looks like a textbox? – Gaffi Oct 4 '12 at 16:52
@Gaffi: The "Ask Question" button on this page is just a link: <a id="nav-askquestion" href="/questions/ask">Ask Question</a>, inside a <div><ul>. I would imagine the Captcha "button" is something similar. – Robert Harvey Oct 4 '12 at 16:56
@RobertHarvey Right, well I suppose that's my point: It's not a field into which you can enter data, however much it may appear to be. – Gaffi Oct 4 '12 at 17:11
I say change it to a button, but configure it to look like a textbox. – Chris Gerken Oct 4 '12 at 19:07
@Nick it's not completed, the site was never updated. – Shadow Wizard Apr 29 '13 at 7:09
I don't understand why some people disagree with this. – hims056 Aug 23 '13 at 7:06
up vote 6 down vote accepted

As mentioned, the problem was simply bad markup - a trailing quote was missing on the style attribute. Apparently it's been this way for at least 17 months, so I'm amazed that this is the first time anyone's noticed.

At any rate, I've fixed it now. Will be deployed in the next build (> 2012.9.7.6).

share|improve this answer
I think everyone noticed. It still functioned as a button though so... – ben is uǝq backwards Oct 4 '12 at 18:12
True, but it would have been a prime target for an "Eeeek! You got your text box in my button!" post. – Tim Stone Oct 4 '12 at 18:17
According to this it's still not fixed. – Shadow Wizard Mar 3 '13 at 12:50
@ShaWizDowArd There hasn't been a new build yet – Tim Stone Mar 3 '13 at 14:26
Oh my... so is it updated once a year?? – Shadow Wizard Mar 3 '13 at 14:41
@ShaWizDowArd No, but it's lower priority than the other stuff Nick has been working on (I have no control over the builds). I'll ask him if he has some time to look into it next week. – Tim Stone Mar 3 '13 at 14:50

It is supposed to be a button. The markup is just screwed up.

<input id="btn-captcha" style="font-weight:bold; type=" button"="" name="submit-captcha" value="&nbsp;I'm a Human Being&nbsp;" placeholder="UNKNOWN_TYPE">

Should be:

<input id="btn-captcha" style="font-weight:bold;" type="button" name="submit-captcha" value="&nbsp;I'm a Human Being&nbsp;" placeholder="UNKNOWN_TYPE">
share|improve this answer

I see markup problems as well, but not exactly the same ones as GEOCHET is getting.

Internet Explorer 8:

<input id="btn-captcha" style="font-weight:bold; type="button" name="submit-captcha" value="&nbsp;I'm a Human Being&nbsp;"/>

There's a missing quotation mark after bold;.

Firefox 10:

<input value=" I'm a Human Being " name="submit-captcha" button"="" style="font-weight:bold; type=" id="btn-captcha">

Not only is there a missing quotation mark after bold;, there's weirdness surrounding button and type. These are the same errors as GEOCHET's, but in a different order.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .