What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

Possible Duplicate:
Post `\` or `\\` in a comment

I just found that \ cannot rendered correctly (without highlight around it) in comment area. When I'm leaving a comment in THIS question. Is this a bug or not? How can I input the \ in comment area?

share|improve this question

marked as duplicate by balpha Oct 12 '12 at 5:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3  
If this question doesn't help, we're gonna need a bit more information. Single backslashes should work fine in comments: \. –  Anna Lear Oct 12 '12 at 4:41
    
@ajax333221 When no backticks are involved, it should just work anyway. I'm going to reopen, leave a link to the possible dupe, and then step away from the internets cause I'm clearly failing at this hour of the night. :) –  Anna Lear Oct 12 '12 at 4:43
    
@AnnaLear thanks for your reply :) –  Kjuly Oct 12 '12 at 5:03
    
@AnnaLear I'm sorry, the workaround of the question you gave still cannot work in comment area... only \ without highlight here.. –  Kjuly Oct 12 '12 at 5:10

1 Answer 1

up vote 1 down vote accepted

I am not really sure what the problem is. On the question you link to, I see this:

screenshot of the comment in question

For the text you entered into the comment box, I see this:

comment editing view of same comment, showing precisely the text that's displayed.

That's 100% identical to what's displayed. And the comment I put below this answer has the same source text as what's displayed.

share|improve this answer
    
Two backslashes: \\ One backslash: \ The end. –  balpha Oct 12 '12 at 5:27
    
Actually, I want to leave it with `` around \\ and \. // is rendered well (with highlight), but `` not (as you see).. –  Kjuly Oct 12 '12 at 5:30
    
What kind of "highlight" are you talking about? There is no highlight on the "//" in your comment on stackoverflow.com/questions/12851980/…. –  balpha Oct 12 '12 at 5:31
    
oops, // is not rendered here either! Please take a look at stackoverflow.com/questions/12851980/… again, I leave a new comment that I want to do. :) –  Kjuly Oct 12 '12 at 5:32
2  
I have edited it to be correct. The answer is here, so it was a duplicate after all. –  balpha Oct 12 '12 at 5:34
    
Oh, that's it! I didn't try it in SO. Thanks! By the way, why it not works in meta.SO :? –  Kjuly Oct 12 '12 at 5:36
    
It works the same way on SO and on Meta. Why do you say it doesn't work here? –  balpha Oct 12 '12 at 5:37
    
What about \? –  Kjuly Oct 12 '12 at 5:38
1  
Looks good to me. I think you're just confused by the fact that code in comments doesn't have such a pronounced background color on Meta as it does on SO. –  balpha Oct 12 '12 at 5:39
    
"doesn't have such a pronounced background color on Meta as it does on SO". Yes it is! –  Kjuly Oct 12 '12 at 5:41

Not the answer you're looking for? Browse other questions tagged .