What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I clicked the invitation link in the email I received. When I log in, it seemingly accepts the login credentials but brings me back to the login screen. My user id and password are correctly entered but have not been able to accept the invitation. The invitation, by the way, was sent to my work email address, which is the one I'm trying to log into the site with.

share|improve this question
2  
Try again? We had a cookie issue that should be fixed now. –  David Fullerton Nov 5 '12 at 23:11
    
@David well, another one had same thing happening. –  Shadow Wizard Nov 6 '12 at 9:38
    
@ShaWizDowArd yes, but in my case it could be related to some issue with the original mail gone missing and the invitation timeout. That said, the behaviour described here is the same - accepted credentials but sent back at the login screen. Also notice that if you don't clear the browser cookies, any attempt to use the same login provider WON'T display the login prompt again. –  SPArchaeologist Nov 6 '12 at 11:14

1 Answer 1

Sorry about that user and thanks for the report. I believe you've been a victim of a couple of our recent login and [invitation acceptance] bugs (14 - 7 = 3: Arithmetic overflow in Careers invitation?) which should both be fixed now. Take another crack at it and let us know if you're still having problems logging in or accepting your invitation.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .