What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I have several Stack Exchange accounts which I access from the OpenID. Yesterday I changed my password through Stack Overflow account, from a computer, which I usually don't use to access any Stack Exchange account. I successfully changed the password and accessed my account from that account.

Just now I tried to access my account from a different computer, but I'm unable to access it. Password recovery is also not working!

share|improve this question
    
What exactly is happening? What error you get? –  Shadow Wizard Nov 12 '12 at 10:36
1  
Have you tried to clear your browser cache? –  juergen d Nov 12 '12 at 10:44
    
@ShaWizDowArd Nothing happens! that's the more annoying thing! When I enter my username and password and click Sign In nothing happens! (the phrase "Sign in with your...", and the text boxes disappear. and that's it!) I'm not redirected to my home page, 'login' option stays visible in the menu, and so on! –  CRoshanLG Nov 12 '12 at 11:06
    
Most browsers today got dev tools with a Network Profiler among them.. open that profiler and see the traffic, it might give you hint about what is failing. –  Shadow Wizard Nov 12 '12 at 11:07
1  
No problems in IE 9! Can anyone please explain me what's wrong with Firefox 16.0.2? –  CRoshanLG Nov 12 '12 at 11:10

1 Answer 1

up vote 1 down vote accepted

I tried clearing the cache like juergen d have suggested, but it didn't solved the problem. Then I tried clearing all the cookies, cache, browsing history, ect (everything!). And restarted the browser! Now the problem is solved!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .