What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

Possible Duplicate:
Can’t login by using ClaimID

I get a certificate error when I try to login today.

I see that there are other questions on a similar topic, but they appear to be older. This looks like a new problem.

When I press the login button on this screen:

enter image description here

I get this error:

enter image description here

share|improve this question

marked as duplicate by Martijn Pieters, animuson, Ben Brocka, Toon Krijthe, amanaP lanaC A nalP A naM A Nov 20 '12 at 21:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Are you trying to use https:// to access the site? That's not supported. –  Martijn Pieters Nov 20 '12 at 15:24
    
I am pressing the login button on this page productivity.stackexchange.com/users/login –  Shiraz Bhaiji Nov 20 '12 at 15:28
    
Which button? You need to be more explicit, there are several there. Can you give us the actual error? –  Martijn Pieters Nov 20 '12 at 15:42
    
The "Log in" button, it points to this link: productivity.stackexchange.com/users/authenticate –  Shiraz Bhaiji Nov 20 '12 at 20:28
    
Oh hey, claimid. I've seen that around a few times lately... –  J. Steen Nov 20 '12 at 20:51
    
Perhaps claimid redirects back to a https url instead of the correct http url. –  CodesInChaos Nov 20 '12 at 20:55
    
@ShirazBhaiji Are you able to login using CLAIMID now? I contacted them and they said they believe the issue has been resolved. It looks like the certificates have been setup correctly now but I dont have a claimid to test with. –  n00b Nov 27 '12 at 16:47
    
@droid, thanks for the help. My browser refreshed and I got a "wellcome back" without having to log in. Claimid still has a problem, the name on the certificate does not match the url. You can see it if you go to this address: openid.claimid.com/login the cert is for claimid.com, the address is openid.claimid.com –  Shiraz Bhaiji Nov 27 '12 at 22:13

1 Answer 1

up vote 6 down vote accepted

No, theres no problem with any Stack Exchange certificates. The problem is Clamid's. You can recreate the issue by hitting their login site directly as well.

enter image description here

Im no SSL expert, but it doesnt look like they have a wildcard SSL certificate, namely it looks like their certificate is only good for claimid.com and not for openid.claimid.com. This appears to be a recent change, as they moved from claimid.com to openid.claimid.com before and now it seems they are reverting (or simply messed up their certificate setup).

According to the certificate dates, it looks like they requested a new certificate (or a renewal) last Friday (11/16/2011). That is, in all likelihood, when the issues began.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .