What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

There is a display error of completeness score in the right sidebar of the careers site. The error is seen on all pages of profile (e.g. http://careers.stackoverflow.com/cv/score/138181). A pair of screen shots of the error attached. First contains the error score (149/210) in the sidebar. Second contains the actual score (151/210) at the bottom grand total.

enter image description here enter image description here

UPDATE:

REPRODUCTION STEPS:

In the Stack Exchange section has 20 points in total, where 10 points are for linking to 5 or more Stack Exchange answers. I have exactly 5 answers linked. My total score should be 151/210. And it is.

Now, on the edit profile page, I remove the bottom-most link, the score changes to 149/210. Then I link an answer (the same one or any other), the total score still remains 149/210, whereas it should be 151/210. I think this is an error/bug, if I am not wrong. Even more, when I refresh this page, the score does not still start displaying correctly. And, if I don't do the following, the score is still the incorrect one. (My profile score is incorrect at present).

Now, there is another bug as well. From the same point above, I click the View completeness report link. On reaching the page, I still am seeing my score to be 149/210 and not 151/210. This is the same as depicted in the images above. But, as soon as I refresh this page, the score starts displaying correctly.

UPDATE 2

The score in green does not get refreshed immediately, but the score in black below gets. Please have a look.

enter image description here

share|improve this question
    
I'd wager the score there is cached. Wait a little while. –  Martijn Pieters Dec 16 '12 at 12:33
1  
@MartijnPieters I had seen this past a week. Today, I tried a lot many things. Sometimes it came back to normal instantly and again started showing the problem. I am trying to note down a list of reproducible steps. Would update the same once I am done. –  Sandip Agarwal Dec 16 '12 at 14:25
    
Closing as duplicate. We've had this problem for a while, it should be fixed by now. Please let us know if there are any further incorrect scores. –  Max Jan 25 '13 at 15:36
    
@Max I am still facing the problem. Would write down the exact reproduction steps for the problem. If possible, please have a look at my profile. Its in the exact state as depicted in the above images. Thanks. –  Sandip Agarwal Jan 25 '13 at 16:27
    
@SandipAgarwal The fix was deployed today. I just checked your profile and it should now display the correct score. Thanks for your feedback, let us know if there are any more problems! –  Max Jan 25 '13 at 19:11
    
@Max I am still receiving the problem in a similar format. I have updated the question to list down the reproduction steps. Please have a look. Thanks. –  Sandip Agarwal Jan 26 '13 at 14:26
    
@SandipAgarwal You're right, this issue is actually different from the one which got fixed last week. Reopening, we'll look into this. Note that, as you're pointing out correctly, refreshing the completeness report will recalculate your score to the correct value. So this be done as a workaround in the meantime. –  Max Jan 28 '13 at 13:47

1 Answer 1

up vote 1 down vote accepted

Fixed. No more incomplete completeness scores, hopefully!

So, what was the problem? Well, when you added a new Stackoverflow question to your profile, we recalculated your completeness score, and then added the question. What we should have done instead is, add the question first, and then recalculate the score. Just like we drink orange juice first, and then brush our teeth. Makes sense? :-) Anyways, thanks for reporting this issue and let us know if there are any more problems!

share|improve this answer
    
I am still receiving the error in part now. UPDATE 2 above explains it in an image attached. Thanks. –  Sandip Agarwal Jan 29 '13 at 17:05
    
So the score calculation is now correct, it just doesn't refresh the upper label until you reload the page - right? –  Max Jan 29 '13 at 17:13
    
Please try again. The score in the sidebar should now get updated instantaneously after adding or removing a SO question. –  Max Jan 29 '13 at 21:02
    
Bingo! Everything working now. :-) Would let you know if the problem persists or new one arises. –  Sandip Agarwal Jan 30 '13 at 5:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .