What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

I'm registered and logged in, asked several questions so far and accepted several answers, but was never able to vote! It says "Please login or register to vote for this post."

What can I do?

share|improve this question
    
just to mention: I always login with my facebook account, I'm on ubuntu, and it happens both in chrome and firefox –  Troy McClure Dec 25 '12 at 2:25
    
somehow it works on mathoverflow but not on math.stachexchange –  Troy McClure Dec 25 '12 at 7:34
    
Check the JavaScript console for errors, maybe it will give some direction. –  Shadow Wizard Dec 25 '12 at 9:20
    
thanks, how can i do it on chrome? –  Troy McClure Dec 25 '12 at 11:02
    
Click on the three parallel lines icon to the right of the address bar --> Tools --> JavaScript console. (Or press CTRL+SHIFT+J) –  Shadow Wizard Dec 25 '12 at 11:23
    
I got into some kind of console (F12->Console), but when I click "vote" i see nothing there –  Troy McClure Dec 25 '12 at 23:24
    
Well, it means no errors. You also have Network tab in the tools, click that tab reload the page and you'll see bunch of requests.. any of those result in error? (Status different from 200 or 304) –  Shadow Wizard Dec 26 '12 at 7:43
    
when i click vote i get some 204 "no content" and one js "pending" –  Troy McClure Dec 26 '12 at 12:00
    
Weird. When I vote, I see only JSON request and same when undoing the vote: i.stack.imgur.com/1akrM.png (first is for upvote, second is for undoing it) can you please post screenshot of what it looks like for you? –  Shadow Wizard Dec 26 '12 at 13:51
    
I have the same problem. Console shows: POST area51.stackexchange.com/users/login/global 404 (Not Found) jquery.min.js:141 c.extend.ajax jquery.min.js:141 c.extend.post jquery.min.js:134 messageCallback global-login.js:57 –  Badger Girl Jun 6 '13 at 20:57
    
@BadgerGirl: I've removed your bounty, since it's impossible to answer this question without knowing more about the problem behind it (that said, please refer to the troubleshooting information in my answer). If you're still having this problem, please contact us using the link at the bottom of the page. –  Shog9 Jun 7 '13 at 0:25

1 Answer 1

A few things to check when you encounter a problem like this:

  1. Make sure you're really logged in: do you see your username at the top of the screen? Do you see the "StackExchange" link and logo to the left of it? Click the little down-arrow next to the words "StackExchange", and verify that you get a drop-down with an "inbox" link at the top (among other things). If you don't see your name, or the drop-down doesn't load, then you're not logged in.

  2. Make sure JavaScript is loaded. Do you see a big bar across the top of the page that looks like this?

    Stack Overflow works best with JavaScript enabled

    Also, make sure you're able to load our scripts from our CDN: can you load http://cdn.sstatic.net/js/stub.js directly? If not, figure out why; it's not gonna work until you do.

  3. Some versions of Firefox have, in circumstances I've never been able to reproduce, a nasty tendency to cache pages that they really shouldn't. Try clearing your cache and history. Yes, really. Don't know why, but that works for some people.

  4. Make sure you're not behind a dodgy proxy or web filter. If you are, all bets are off.

  5. Make sure you're not trying to force a HTTPS connection to the site (with a tool like HTTPS Everywhere) - until SE supports HTTPS, this is going to have bad results.

Unfortunately, there are a lot of things that can go wrong, so it's impossible to know for sure what's causing your problem without more detail.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .