Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

This isn't a serious problem but in Stack Exchange flair tooltips, there is some problem with rendering Turkish characters; they are being double escaped when converted to HTML entities. The following characters have that issue -

ç, ğ, ı, ö, ş, ü.

enter image description here

share|improve this question
up vote 6 down vote accepted

As far as I can tell, combined flair tooltip looks broken because img title attribute uses & instead of ampersand that works fine in ordinary flair.

Bug was easy to see at your flair page: http://stackoverflow.com/users/447156/soner-gonul/flair (as reproduced at screen shot below; note it has been recently fixed).

When hovering over your combined flair tooltip shows ö instead of ö (see screen shot below, tested with Firefox and IE). This page also shows how to do it right - ordinary flair tooltip, with plain ampersands in title looks OK.

  • snippet of combined flair code:
    title="profile for Soner Gönül on Stack Exchange..."

  • for the reference - snippet of ordinary flair code:
    title="profile for Soner Gönül at Stack Overflow..."

Note that alt attribute in combined flair code appears to have the same issue.


http://i.stack.imgur.com/Zstzs.png


A workaround for this bug is to manually replace & when copying combined flair code.

  • If corrected that way, tooltip looks OK:
    profile for Soner Gönül on Stack Exchange, a network of free, community-driven Q&A sites
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .