What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

In past I didn't have this problem, but now if I try to edit an answer, I always get an error:

enter image description here

After this I usually reload the page, if I see that the message has been actually edited (so I got the error message box for no reason) I don't do anything, otherwise I try to edit it again. Why do I always get this error?

share|improve this question
2  
Or a question... just refresh the page and it goes away; my edits have always been "saved". Of course, it'd be great if it stopped... –  ben is uǝq backwards Jan 14 '13 at 22:47
    
does it happen every time you edit, or only some of the time? –  Sam I am Jan 14 '13 at 22:51
    
It happens almost every time at the moment. There have been other problems today as well, my guess is that the SE sysadmin team is working on it already. –  Martijn Pieters Jan 14 '13 at 22:55
    
Also see twitter.com/stackstatus/status/290649005556391937 (20 hours ago). –  Martijn Pieters Jan 14 '13 at 22:55
    
Seems to happen to me every time, too. –  Kerrek SB Jan 14 '13 at 23:06
    
Now seeing this while editing a question of mine. The edits are actually going through, just the error is showing up. –  Charles Jan 14 '13 at 23:45

1 Answer 1

up vote 5 down vote accepted

A fix for this is about to roll out.

Has now been deployed, if you see further errors let me know.

Recently I redid an awful lot of the edit pipeline, and there was a bug dealing with quick edits (no revisions) in the ajax editor. Kind of a pain to reproduce locally honestly, but pretty common on the site itself.

The underlying bug was that we were responding with redirects to some ajax calls, which went to html, which our javascript couldn't parse, which was then reported as a generic error. All the edits went through successfully though.

share|improve this answer
    
Was this also responsible for the convert to edit bug? –  casperOne Jan 15 '13 at 2:53
    
@casperOne different bug, same pipeline. –  Kevin Montrose Jan 15 '13 at 3:04
    
Is it fixed then i.e. are all bugs that extend from the pipeline fixed because the pipeline is fixed? –  casperOne Jan 15 '13 at 12:28
    
@casperOne The convert to edit bug was fixed yes, the pipeline has no known bugs at the moment. This may not be the same as no bugs though... –  Kevin Montrose Jan 15 '13 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .