What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

Here's what is happening; everytime I go to Stack Overflow (stackoverflow.com, NOT meta) with Firefox, it gives me the "Welcome back" tab that pops up from the top. Whenever I click in the "click here to refresh the page" link, all it does is refresh the page without logging me back in.

Even if I try to log in using the "log in" button at the top, all it does is pop up the tab that says "Welcome name here, you're being redirected." The problem is I'm not being logged in, not to mention that it keeps refreshing the page over and over again without giving me a choice to log in with Facebook.

For some reason, I was capable of logging in to Meta Stack Overflow using Firefox. I am still unable to log in to Stack Overflow. Any ideas?

share|improve this question
3  
Only the usual "clear your cache and cookies" advice. –  Robert Harvey Jan 29 '13 at 16:38
3  
I am having this problem with Firefox 20.0.1 so I'm up voting this question –  Peter May 10 '13 at 12:01
3  
I wanted to upvote, but couldnt log in...... –  mjs Jan 23 at 13:27

4 Answers 4

up vote 41 down vote accepted

For Firefox... try clearing your browser history. It sounds dumb, but that's usually what causes this behaviour.

If that doesn't work, try the usual "clear your cache and cookies".

Note that the above also applies when you did a fresh install of Firefox, and imported settings from another browser during installation.

And if that doesn't work, drop us a line from http://meta.stackoverflow.com/contact.

share|improve this answer
18  
If you don't want to clear your whole history you can open the History panel, search for stackoverflow.com and rightclick on the entry for that - then you can select 'forget this site' and it'll wipe it from your history but leave all the other history in place. –  JonW Jan 29 '13 at 16:58
    
@JonW Ooh, that's an interesting feature I didn't know about! –  Andrew Barber Jan 29 '13 at 17:17
    
@AndrewBarber: Yeah it's great. Testing new projects has become much less of a PITA now I don't have to clear my entire history each time. –  JonW Jan 29 '13 at 17:19
    
Also one might want to check Network Login Troubleshooting. Any reason why that is not listed on the /help page, @Anna? (It seems that page also checks the local system time; if not then it's always good to check that too.) –  Arjan Feb 16 '13 at 11:15
    
@Arjan that is an excellent idea. –  Anna Lear Feb 16 '13 at 18:05
    
Anna, if you're adding meta.stackoverflow.com/network-login-help, then please also note those tests seem to use HTTP to check communications with stackauth.com. However, the real login seems to need HTTPS. Maybe the test is easily changed? –  Arjan Feb 25 '13 at 22:30
    
clearing cookies worked for me –  Suraj Chandran Jul 12 '13 at 18:16
    
For future reference: is meta.stackoverflow.com/contact the new meta.stackoverflow.com/help (and as an side: the Network Login Troubleshooting is still not linked)? –  Arjan Jul 18 '13 at 11:34
    
@Arjan Right. Do you have the link to the login troubleshooting page handy? –  Anna Lear Jul 18 '13 at 16:04
    
From a few comments up, @Anna: meta.stackoverflow.com/network-login-help :-) –  Arjan Jul 18 '13 at 22:27
    
If it's indeed a Firefox issue. It'll be great if someone investigates it, and post issue to Firefox's project bugzilla. Clearing history can hardly be accepted as final solution. –  Mariusz Nowak Feb 14 at 8:40
    
Works indeed. Strange that history is the one causing it. –  Jus12 Oct 7 at 5:20

Clear ALL cookies!

Go to Options > Privacy > Remove individual cookies > Remove all cookies

I tried clearing the browser history and by default Firefox offers "Recent history" when trying to clear the cache so probably that's why @Anna Lear's answer didn't work for me.

I got in touch with SO support and s/he asked if Firefox works on SO in private browsing mode, which it does. Then in a duplicate question the user mentioned that they didn't have the problem in Firefox when they installed without importing the Settings from Chrome. Therefore, I figured it had something to do with cookies (yum) apart from that I'm a bit lost.

Does anyone know what is going on in the background? A poison pill from Chrome perhaps? I'm curious.

share|improve this answer
    
clearing stack's cookies worked for me. thanks –  pipwerks Feb 20 at 5:43

The cookies imported from Chrome into FireFox (Version 29 for me atm) related to the StackExchange network won't work properly. To remove just those cookies in version 29, do the following:

  • Click on the FireFox menu (the 3 lines stacked)
  • Click the Gear icon (Options)
  • Click the Mask icon (Privacy)
  • In the History sub-section, click the link remove individual cookies
  • In the search box type: stack
  • Click / select the first cookie shown in the list
  • while holding down shift, scroll to the bottom of the list
  • continue holding shift, and click on the very bottom item of the list
  • with the entire list highlighted, click Remove Cookies

You should now be able to log in properly on the components of StackExchange.

share|improve this answer
    
This let me resolve the problem without losing any other site cookie data or browsing history, both of which are very important to me. And it was very easy to follow. Simply refresh Stack Exchange sites after the procedure, and it will automatically log you in and ask you to refresh again. That's it! –  ADTC Jun 16 at 2:24
    
It will be worth noting that you will also need to clear cookies named superuser as well. And any other SE sites that don't have the keyword stack in their names. –  ADTC Jun 16 at 2:52
    
Perfect it worked. This solution is much better than deleting your browser history. After all, that's exactly what we wanted when importing Chrome history to Firefox. –  goamn Jul 24 at 1:30

To be more specific, you only have to clear the cookies from SO- nothing else. You will have to clear separately for MSO (and presumably other sites like Programmers) which seem to store theirs separately. After that, you will be automatically logged in again but this time it works.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .