What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

This is a constant issue with me. If I do not post for even a few minutes and then try posting in chat I encounter this error:

enter image description here

It happens for any type of message, I am forced to refresh the chat window for it to allow me to post messages again. It's becoming a bit of a nuisance as any formatted message has to be completely redone as I can't edit the message after it sends and errors. Also clicking retry does not help as it just repeats the error message. What could be causing this and is anyone else experiencing it?

UA : Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0

share|improve this question
5  
that is the chat interpreters way of nicely telling you that you should finally get to sleep ;) –  Gordon Mar 6 '13 at 11:36
    
@Gordon But there is so much work to be done! =oP –  cryptic ツ Mar 6 '13 at 11:37
    
Are you using the user script for posting the cv-pls stuff? Or does this happen for every chat message? –  Mad Scientist Mar 6 '13 at 11:37
2  
I suggest you to stop using IE :) –  Rikesh Mar 6 '13 at 11:38
    
@MadScientist it happens with any type of message. cv or just a regular message. It happens if I don't have activity for awhile and then try posting. –  cryptic ツ Mar 6 '13 at 11:38
2  
@crypticツ yes, but you gotta keep a sustainable pace. Otherwise you'll burn out soon. I wouldnt want that. Who'd give free hugs then? –  Gordon Mar 6 '13 at 11:38
    
@MadScientist I've had it happen as well, it's completely at random and I've actually never had it when the using the extension (that I recall). Either way, I don't believe that's the issue because all we do is populate the input with text (just as if you had typed it in) and trigger the click event on the send button. We don't try to be clever and hook the SE codez because I have a feeling that wouldn't go well. –  David X. Random Mar 6 '13 at 11:39
2  
chat is getting angry because you don't use chrome –  Wesley Crushed Mar 6 '13 at 11:40

1 Answer 1

The most common reason for this is that you logged out and back in on a different browser window while being in the chat room. We recently made a change to the Q&A site to detect and automatically fix this issue, and we're planning to do something similar with chat as well.

Until then, if this happens again: Just press the up arrow key before reloading the page. This will edit the last message you posted, and the chat remembers the content of the input box. Thus the text will still be there after reloading, and you can submit it.

share|improve this answer
    
I tried it out by making sure to not open any new window with s chat and still it errored, also the up arrow did not allow me to edit the errored message. –  cryptic ツ Mar 6 '13 at 12:06
    
Do you have an anticipated time frame this fix will be released for chat? It's driving me bonkers having to constantly refresh page. However, no hurry I know you guys are busy. =o) –  cryptic ツ May 2 '13 at 7:27
    
@crypticツ What do you mean, "constantly"? You must be seeing a different problem. The thing I mention here should happen once, not contantly. –  balpha May 2 '13 at 15:08
    
every few messages I have to refresh the page if it was a couple of minutes between last message otherwise the error appears. This happens even if I am in a single chat room and with no additional chat tabs open. –  cryptic ツ May 2 '13 at 20:58
    
Was this change ever implemented into chat? I still keep getting these error messages. –  cryptic ツ Oct 17 '13 at 20:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .