The title doesn't fully cover the problem; on SO, I can change my e-mail by editing my profile, but it won't let me login with it. It tells me no account is associated with that particular address.

When I try logging in with my old email address, everything works fine. But I see my new e-mail in my profile. I don't see any reference to the old email, but still that's the address SO expects me to login with.

How can I change my mail address?


Using several other answers on Meta I actually managed to get on the 'new account' page. Major success. I filled out the form, clicked 'send' and then:



enter image description here

share|improve this question
You need to add new login, the email address is not relevant to login just to your profile picture and emails you get from the site. –  Shadow Wizard Mar 6 '13 at 20:18
@ShaWizDowArd Maybe, maybe not. None of the answers on that page would help this user: he doesn't need to change his logins, he just needs to change the email address associated with his Stack Exchange OpenID login. –  Jeremy Banks Mar 6 '13 at 20:25
As ever time this is mentioned, I repeat: The user experience in this area is absolutely ridiculous. Even though I expect it to be fixed soonish, it's still quite a shame that this mess been allowed to continue for so long. –  Jeremy Banks Mar 6 '13 at 20:26
@Jeremy fair point, OpenID isn't something really trivial. –  Shadow Wizard Mar 6 '13 at 21:39
Hi! I'm an SE employee and I'm going to try and help you solve this. So, just to be certain, you're not using any sorts of proxy or VPN at all? How about any kind of adblocker or extension that blocks anything? –  Aarthi Mar 18 '13 at 21:25
Not at all sir. –  Sherlock Mar 19 '13 at 7:58
Edit: madam. ;) –  Sherlock Mar 19 '13 at 8:45
It suddenly works again. I have been able to change my mail address and delete my old one... I have no clue what caused the initial error page, but two things are for sure: the procedures themselves are very inconvenient and are - at least sometimes - flawed (given the error page I was presented with). Thanks for your help nevertheless. –  Sherlock Mar 19 '13 at 10:19
This happened to me today too. My Stack Overflow account OpenId login is my work email but I am planning to switch employers so I wanted to switch it to my personal email. I changed the email that notifications are sent from to my personal email but I still need to login with my work email or I get the following message: "No account with this email found". I also tried but it does not give me an option to change my email, only my password. –  Kmeixner Mar 19 '13 at 19:49
add comment

1 Answer

up vote 5 down vote accepted

The email address you see and can edit in your profile is not the same as the email address used for your login. This is confusing, because your login email address is initially used to populated your profile email address but is entirely disconnected after that.

The email address used to login isn't directly tied to your Stack Overflow account, it's connected to a Stack Exchange OpenID account that was created when you registered on Stack Overflow. You can log in and manage this at

share|improve this answer
What a bloody mess. The whole registration / logging in procedure is so, so flawed and ugly compared to the rest of the site. This answer helped me out though, thanks alot. –  Sherlock Mar 6 '13 at 20:35
Actually, I'm lost again. When I click 'add more logins' it redirects me to the usual login / sign-up page, where I can choose to create a new Stack Exhange id. When I click that, I automatically get (re)logged in and land on the normal page here on Meta. Any clues? –  Sherlock Mar 6 '13 at 20:39
Also; this is ridiculous. –  Sherlock Mar 6 '13 at 20:40
Oh, there's a third account to be aware of: in addition to being logged in to your Stack Overflow account and your Stack Exchange OpenID account, you're also logged into a semi-hidden Stack Exchange network account! This is what's causing you to be automatically logged in to Stack Overflow after you log out. You can clear that at –  Jeremy Banks Mar 6 '13 at 20:45
But as far as I know you shouldn't need to use "add more logins". You probably want to keep your existing Stack Exchange OpenID account that is associated with your Stack Overflow account, you just want to change its email address which you should be able to do at I think. (This aspect of the site irritates me more than almost any other. edit: Resetting the throttle each time you try to post a second comment within 15 seconds may be more infuriating.) –  Jeremy Banks Mar 6 '13 at 20:46
Call me stupid, but I only see a 'change password' link there. It doesn't mention a way to change the corresponding e-mail address. I tried doing it by clicking 'add more logins' over and over (I did clear the global thing), but it keeps forwarding me to Meta. I feel like a complete noob to be honest. Usually I'm on the other side of this drama. :') –  Sherlock Mar 6 '13 at 20:51
@Sherlock Oh, damn, my mistake. I misread the page, it looks like you are correct and it isn't possible to change the email associated with that account. Gaaah, sorry for misleading you. You picked a bad time to ask for help; most of the users that would usually be reading meta are awaiting the Town Hall Chat for the current election, which starts in a few minutes. –  Jeremy Banks Mar 6 '13 at 20:54
I'm in no hurry whatsoever, thanks anyway! –  Sherlock Mar 6 '13 at 20:55
How do I start a bounty on this? –  Sherlock Mar 11 '13 at 9:16
@sherlock Unfortunately you cannot because this question has been closed. Gah. To fix tpur problem i guess I suggest you send a message via the "contact us" form linked in the footer. They should be able to sort you out. :/ Sorry but I've been busy, or I'd have tried to create a test account and figure out what works. –  Jeremy Banks Mar 11 '13 at 11:37
@JeremyBanksᐛ a simpler way to make sure you're not logged in when doing this is to use Chrome's Incognito tab –  Toby Allen Mar 11 '13 at 19:04
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .