What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

All, I have noticed that all the code formatting for questions or answers new or old is 'flat'. That is all indentation of the code is gone even when the code has the required four-spaces allocated at each level. Is there maintenance going on, or is this a local problem (i.e. just me)? If it is a problem others are experiencing, when will this be fixed?


Edit A. This is occurring with ALL posts for me. I have not changed any browser options (Although with Explorer it may have decided to change itself!). Here is an example of some C# code, that is correctly formatted with spaces not some other special characters:

enter image description here

Edit B. To address the fact that this is a 'Killercam not formatting properly error' I attach a screenshot of one of @Makoto's answers with the formatting "busted"!

enter image description here

share|improve this question
6  
Most likely you are not using normal spaces, but other unicode characters that appear to be spaces. Do you have an example? –  Nick Craver Mar 28 '13 at 14:04
1  
Can you give an example? –  Linuxios Mar 28 '13 at 14:04
1  
It happened to me to, and in all the case the browser on the Mac inserted strange characters that seemed white spaces. –  kiamlaluno Mar 28 '13 at 14:16
    
I understand this could be a browser issue, but I have not changed any options what-so-ever. This started happening for all code blocks on the site yesterday evening... –  Killercam Mar 28 '13 at 14:28
1  
I don't really notice an issue elsewhere...are you certain that this particular post was "properly" formatted before? –  Makoto Mar 28 '13 at 14:38
2  
Can you post an answer with a code block in the formatting sandbox, and then provide a link? –  David Robinson Mar 28 '13 at 14:43
    
@Makoto I have edited the question to show one of your answers with the same code formatting problems! –  Killercam Mar 28 '13 at 15:07
    
@DavidRobinson I don't have enough rep (10 points) to answer it... –  Killercam Mar 28 '13 at 15:22
    
@killercam: how about now? –  David Robinson Mar 28 '13 at 15:24
    
@DavidRobinson meta.stackexchange.com/a/174006/164125 –  Killercam Mar 28 '13 at 15:39
    
@Killercam: It looks like it's formatted fine to me... –  David Robinson Mar 28 '13 at 15:40
    
Okay cheers, it must be my browser, but god knows how to fix it... –  Killercam Mar 28 '13 at 15:42
1  
Well...on my box it looks fine. Include which browser and version in this report. –  Makoto Mar 28 '13 at 15:58
1  
This is Microsoft's IE10. Version 10.0.9200.16521. –  Killercam Mar 28 '13 at 16:51
    
Any ideas how to fix this? –  Killercam Mar 28 '13 at 18:26

1 Answer 1

Okay, this turned out to be an Internet Explorer issue. The version number of the current build of IE10 is Version 10.0.9200.16521.

Now for the fix. Somehow, compatibility view (not shown in the search bar by default was switched off). This needs to be switched on to correctly format the code which is displayed on the StackExchange sites. To do this Options -> F12 Developer Tools -> Browser Mode switch this to 'IE10 Compact View'. Done.

share|improve this answer
    
FWIW, I'm running exactly the same version of IE10 as you, and I don't see an issue with directly typed or code pasted from Visual Studio. I'm not using compatibility mode. That said, I had a commercial WYSIWYG editor blow up after upgrading to IE10, so it's very possible that IE is related to your issue. –  Tim Medora Mar 28 '13 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .