What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

There are two options in the April Fools "chat with an expert" window:

  1. Not now
  2. Never

I've clicked on Never many times, but it keeps popping up. How can I hide this box permanently?

share|improve this question
    
Does the "Nevermind, I saw it again here." in the answer you just deleted mean that on the same site and in the same browser that you previously clicked "never", the box appeared again? That indeed should not be the case. –  balpha Apr 1 '13 at 6:32
    
@balpha After I posted my answer I saw it again. that is why I deleted my answer. So, I clicked never twice on the same site! –  shnisaka Apr 1 '13 at 6:34
    
In the same browser? –  balpha Apr 1 '13 at 6:36
2  
@balpha yes.. and without closing it.. and without deleting a cookie. the box appeared again now while I am talking to you –  shnisaka Apr 1 '13 at 6:39
    
What browser is it? What do you see when you put alert(localStorage.getItem("adviza:leavemealone")) in your JS console? –  balpha Apr 1 '13 at 6:42
    
Timestamp: 4/1/2013 01:46:54 ص Error: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.localStorage] Source File: javascript:%20alert(localStorage.getItem("adviza:leavemealone")) Line: 1 –  shnisaka Apr 1 '13 at 6:47
    
FireFox 20 Beta –  shnisaka Apr 1 '13 at 6:48
    
You do know today's date? –  hjpotter92 Apr 1 '13 at 6:50
5  
@hjpotter92 Did you actually read the question? –  Michael Mrozek Apr 1 '13 at 6:51
    
@MichaelMrozek Yes, I did. And my point still stands. The options can also be there to just be there and not-for-work. –  hjpotter92 Apr 1 '13 at 7:01

1 Answer 1

up vote 11 down vote accepted

It appears that you don't have localStorage available. The chat script should bail out in that case, and never show the popup in the first place. Why it doesn't do that I don't know, but given that you're running a beta browser, I'll assumes that this is one of the many niceties that happen in beta browsers and which are precisely the reason we don't support them.

Please let me know if you can reproduce this in a supported browser.

share|improve this answer
    
I cannot argue with over NINE THOUSANDS rep user. the problem only happens with this specific browser. –  shnisaka Apr 1 '13 at 7:07
    
Yes. I just clicked on Never after reading the question. Now I am not able to chat with bots. (Chrome 25.0.1364.172 m). –  hims056 Apr 1 '13 at 7:07
    
And is there any option to re-chat with bots? –  hims056 Apr 1 '13 at 7:08
    
@hims056 just visit any other stackexchange website such as : stackexchange.com and you will see the message again. or use the same browser that I am using :P –  shnisaka Apr 1 '13 at 7:10
3  
@hims056 No UI, but you can just put localStorage.clear() into the JavaScript console. –  balpha Apr 1 '13 at 7:11
    
I'm running Firefox 3.5, and the stupid non-joke does show and the "never" button does not work. Please do something about such annoying things next time you introduce any. –  tohecz Apr 1 '13 at 20:45
    
@tohecz why not IE6 on Windows 95? Come on you can't expect any site to work properly on ancient browsers. –  Shadow Wizard Apr 1 '13 at 22:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .