What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

I am unable to post questions on Stack Overflow. I am using IE8. Is that a supported browser? As far as I can remember I was able to post questions earlier. Here's the JavaScript error:

"JSON is unidentified"
full.js Line 108
Code:0 Char 405

URI:http://cdn.sstatic.net/js/full.js?v=0608347743ce

share|improve this question
1  
Offically speaking, no, IE8 is not supported. I'd be surprised if it failed that quickly after falling off the supported list, though. –  Michael Petrotta Apr 5 '13 at 0:42
    
@Michael Petrotta that is bad news for me :( Basically mean can't post anything from office :( . Any workarounds? –  misguided Apr 5 '13 at 0:46
    
Well, just 'cause it's not officially supported, doesn't mean that the kind folks at SE won't look at the issue. Give them a little time. But, can you install and use Firefox or Chrome? –  Michael Petrotta Apr 5 '13 at 0:49
    
@MichaelPetrotta sadly I don't have the access to install the said browswers on my system :( –  misguided Apr 5 '13 at 0:54
    
You don't, by chance, have compatibility mode turned on, do you? –  Cody Gray Apr 5 '13 at 4:29
    
@CodyGray You beauty.I had that enabled.Disabling it resolved the issue.I am not getting an option to mark up your answer :( –  misguided Apr 5 '13 at 4:49
    
It wasn't really an answer. All I had was a suggestion, so I just posted a comment. I've upgraded it to an answer, so you should be able to accept it. Glad that worked for you! –  Cody Gray Apr 5 '13 at 4:53
add comment

1 Answer

up vote 4 down vote accepted

You need to disable compatibility mode in your browser:

Sometimes, either for entirely inscrutable reasons or those that are simply beyond my comprehension, this mode gets inadvertently enabled in IE. This reverts its rendering logic to something out of the stone age, thus preventing the proper display of pages.

IE should remember your setting once you explicitly disable it. But the team might still want to investigate if there's something about the content being sent to the host that is causing IE to automatically flip the "compatibility flag" mode on.

Although, like has already been pointed out in a comment, IE 8 is currently an unsupported browser. We strongly recommend upgrading to a newer one. It will improve your Internetz.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .