What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

Yesterday, I was browsing the mobile Stack Overflow site. I noticed one thing: the textareas where you write your comments/answers are very buggy. I'm using a Samsung Galaxy S2, with the standard Android browser (Android version 4.1.2). There are a number of things that aren't working when typing your comment/answer.

  • Automatic spacing with Swype is disabled (however this might be because of Swype, not the site).
  • Text navigation buttons (step left, step right, select text, copy text etc.) doesn't work with the on-screen keyboard, and selecting text by holding your finger over text is extremely difficult.
  • When you paste something it always seems to be pasted at the top of your text, no matter where you try to paste it.
  • Replying to another comment ("@Example User") does not show suggested people to reply to, like the full site does.

Is there anything I can do to solve these issues/bugs, or is it in the hands of Stack Overflow itself, and if so, should it be looked into?

Edit: I was using the mobile version of the site when noticing these bugs.

share|improve this question
    
where you using the normal version or mobile version of site ? –  Lucifer Apr 23 '13 at 13:34
    
I was using the mobile version of the site. Will put that into my question. –  Simon Carlson Apr 23 '13 at 13:35
    
Posted from my pain-free iOS device. –  Undo Apr 23 '13 at 13:43
    
Sorry, it's just that none of the bugs mentioned show up in iOS on the mobile version. –  Undo Apr 23 '13 at 13:44
    
I understand that, most likely because Android and iOS devices use different browsers. However I'm not the only one with an Android :) There's gotta be a solution to these bugs to make browsing smoother, for everyone! –  Simon Carlson Apr 23 '13 at 13:45
    
Android w/mobile Chrome, here. Only thing I repro us the last item; not sure it is meant to be a feature. (Autosuggest on tags works for me) –  Andrew's a Unitato Apr 23 '13 at 13:48
    
What Android version are you running? And yes, autosuggest on tags works for me as well. –  Simon Carlson Apr 23 '13 at 13:49
2  
Do I have to admit? (2.3.6) –  Andrew's a Unitato Apr 23 '13 at 13:52
    
Anything you say can and will be used against you. Try going on the mobile SO site with the default browser instead of Chrome and check for bugs? –  Simon Carlson Apr 23 '13 at 13:53
    
Of those issues only the last one seems related to SO, rather than your keyboard/input app. –  George Duckett Apr 23 '13 at 13:54
    
I realize that, however SO is the only site where I have run in to these problems, or anything close to them, hence my question. –  Simon Carlson Apr 23 '13 at 13:57
    
I'm on Android Chrome, and paste doesn't work at all for me. –  SSumner Apr 23 '13 at 16:40
add comment

1 Answer

Your first three points seem to be related to swype and not our site directly. The fourth point is by design -- the mobile site has limited functionality and name autocomplete is not supported on it.

share|improve this answer
    
Related feature request: meta.stackexchange.com/questions/197719/… –  Shadow Wizard May 14 at 12:03
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .