What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I found a job opening that suited my skill set rather well, and the skill set of a colleague that I know is actively looking. So, I wanted to send them the information via mail.

If I click on the link, I'm taken to a new window. If I Control+Click, I'm taken to a blank new tab.

Here's the page. I'm on Google Chrome 27.0.1453.65 beta, with Linux Mint 14.

share|improve this question
    
What browser are you using? Works fine for me in Chrome and Firefox –  Michael Mrozek May 11 '13 at 23:00
2  
That's a "mailto:" link. It works just fine, opening the mail client set as default on the machine.. –  Shadow Wizard May 11 '13 at 23:00
    
It's the case that I do have a default mail client on my machine, but it's simply not opening it. Typically my mailto links open in Thunderbird or GMail, depending on the machine I'm on. –  Makoto May 11 '13 at 23:04
    
Hmm... maybe because there's no recipient to the mailto? Worth trying to reproduce on jsfiddle, will do it tomorrow if I don't forget. –  Shadow Wizard May 11 '13 at 23:08
    
Actually, this is weird. When I click on Mail to a friend in Firefox, it opens a new (empty) Chrome tab. –  Emrakul May 12 '13 at 5:00
    
@Makoto what happens when you click on a non-empty "mailto:" link? For instance, click on "contact us" at the bottom of careers.stackoverflow.com. –  Max May 13 '13 at 15:29
    
@Max: Same thing. Opens up in a new tab window. –  Makoto May 14 '13 at 1:00

1 Answer 1

up vote 2 down vote accepted

As pointed out in the comments, "Mail to a friend" is a mailto: link. It's supposed to launch your local email client and fill in subject and body of a new email for you:

Subject: <job title>

Body:  
I found this job on Stack Overflow Careers:

<job title>
<page url>
<A few words from the job description>

Since this doesn't seem to work on your machine, an obvious workaround is to copy&paste and create the email manually. Also, re-installing the latest version of your email client could fix the problem.

share|improve this answer
    
A properly configured mail client does actually resolve the issue -mailto links work as expected. –  Makoto May 27 '13 at 2:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .