Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

This question already has an answer here:

I have about 1700 rep on SO, meaning I can retag questions without review, but I cannot edit, yet.

I have problem with one specific question (and some other earlier, but I have not reported the problem then):
Daily Cup of WinSCP file Download with todays date

I click Edit link, change the tags, click Save Edits, but I get error message for the main "question" input box, saying "Edits must be at least 6 characters; is there something else to improve in this post?"; and another for Edit Summary, saying "Your edit summary must be at least 10 characters".

It would make sense, if I made small edit inadvertedly in the post. But I did not. I've tried like dozen times. Both in full and mobile version of SO. No luck.

If I specify Edit Summary, I get rid of the latter error message. But I cannot get rid of the first.

I'm not getting the problem when re-tagging with other questions.

share|improve this question

marked as duplicate by Sklivvz Jan 30 '14 at 13:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

That question's body can be improved in at least two ways: Indent the code/command, and remove "Thanks". – Rob W May 13 '13 at 11:09
Can you show the screen show what exactly you are doing? Because I just retagged a question where I don't have edit privilege. – hims056 May 13 '13 at 11:09
@RobW - He is not talking about how can I avoid this error? but he is asking why is he getting this error when he is just retagging? – hims056 May 13 '13 at 11:11
I think that it's a bug. I've encountered this behaviour before also. Seems to be related to the retag feature being merged with editing. See the link I posted above. – Ren May 13 '13 at 11:12
There is/was something wrong in the question's body that got automatically removed as soon as you clicked on the edit button - looks like (possibly strange) whitespace at the start. I just clicked edit then save, and the non-edit got saved... Can you try again on that question? – Mat May 13 '13 at 11:12
@hims056 I was pointing out that the post contained rooms for improvements. It might be possible that The System detects this (e.g. by scanning for "Thanks"), and refuses to accept a minor edit. This is pure speculation, hence I didn't add it to my first comment. – Rob W May 13 '13 at 11:13
@RobW - Yeah that can be possible through quality filter. – hims056 May 13 '13 at 11:13
@Mat I supposed that is something like that. And indeed after your edit, I could retag without getting the error. – Martin Prikryl May 13 '13 at 11:16
@hims056 I cannot produce a screenshot anymore, after Mat's edit, as I'm not getting the message anymore. But I hope the problem is now more clear anyway. – Martin Prikryl May 13 '13 at 11:17
Turns out it was only a very ordinary CR/LF at the very start of the post that got auto-removed on editing. That's a bit strange since that post is very recent, I would have thought that would have been removed before the post was initially saved. Impossible to spot while you're editing AFAICT, I didn't think hitting save would have done anything. – Mat May 13 '13 at 11:25
@Mat I think it happens because those characters are removed from the revisions, but they are still visible in the post until the post is going to be edited. It happened to me too, to see a post containing a word that vanished when I tried to edit it in a site when I have the permission to edit any post. The strange thing is that the change has been attributed to the user who was trying to add a tag, when it was an automatic edit. – kiamlaluno May 13 '13 at 11:43
Is there anything else I should/could do, to get this fixed? (as it looks like a bug). – Martin Prikryl May 13 '13 at 13:29
@Martin: you've done your job, i.e. reporting the issue here with the [bug] tag. This doesn't seem ultra-high priority, so might take a while for a dev to look into it. (Or not, you never know :-) ) – Mat May 13 '13 at 14:23
up vote 3 down vote accepted

Problem was caused by post editor cleaning up (otherwise invisible) leading CR/LF from the start of the post automatically. This makes it believe that the post text was updated by reviewer/editor, and subsequently requiring a minimal edit of 6 characters to be completed.

Seems to be a bug.

share|improve this answer

There is another example here on meta showing the same behavior:

My question has been marked as a duplicate, but it isn't one

I tried to retag it, but couldn't because the editor stated that I have to change at lease six characters. I don't think however there is anything I can to to improve the question text greatly - apart from retagging it as and .

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .