What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

Over the past week or so, I've noticed a significant slow down of the SE sites I frequent, namely, stackoverflow.com, superuser.com and russian.stackexchange.com. Most of the times, the load time for the site is in 30-40 seconds interval.

On further investigation, it seems that cdn.sstatic.net is the culprit, specifically files stub.js and all.css that are loaded from that domain - it takes about 20 seconds for each of the files to load. Ping response from cdn.sstatic.net is fine (about 2-3 ms), therefore it must be something with the web server response. Sometimes everything is fine, but most of the times the load time makes the site all but unusable. Here's the screenshot from the firebug showing 18+ seconds load for each of the two files.

enter image description here

I get this behaviour both, from my work machine (linux ubuntu laptop, both firefox and chrome) sitting behind the corporate firewall, and my home machine (macbook pro, os x, both firefox and safari).

It's worth noting that the issues started manifesting themselves only about a week or so ago (maybe slightly more than a week).

I found this post about similar issues, dated 2 years ago, but I would hope this is not really an ongoing issue.

I'm accessing the sites from London, UK (work) and from Woking, UK (home).

share|improve this question
    
Well, it's working fast as usual here (Israel) and I'm sure that if it was slow to everyone Meta would have been flooded with reports. So it's local to your area/ISP/proxy. Try Start --> cmd --> tracert stackoverflow.com and see where it get stuck. –  Shadow Wizard Jun 3 '13 at 10:42
    
@ShaWizDowArd Thanks for your comment. I stated in my question that ping is fast - and traceroute is fast too (btw, I don't have windows machine - only linux and os x, so it's traceroute, not tracert). Further, the issue is not with stackoverflow.com but cdn.sstatic.net. Possibly, it's only from my area/isp - henece I'm indicating where I am and that I'm experiencing the issue from two separate ISPs. –  Aleks G Jun 3 '13 at 11:02
    
Well, it appears the cdn.sstatic.net is sometimes slow/unavailable for whole countries, e.g. pretty recent report about French. In all cases it gets back to normal by itself. –  Shadow Wizard Jun 3 '13 at 11:04
    
I would hope so - but it's been a week at least now. –  Aleks G Jun 3 '13 at 11:05

You must log in to answer this question.

Browse other questions tagged .