What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

I posted a question, and someone replied. I want to reply to the guy, but I click "add comment" and "answer your own question" and nothing happens. Someone suggested I have to wait 24 hours; is that correct? Is this a non-traditional forum where you can't reply back to other people's answers?

share|improve this question
add comment

6 Answers

I'm having the same issue, but it's a year since this thread was discussed (should I ask a new (identical question if this thread is too old?).

I have NoScript installed, but disabled it and restarted FF. Still no dice. The "add comment" button is "clickable" (the mouse pointer changes), but clicking does nothing -- same goes for the "Answer" button. Asking a new question (and editing it) works just fine.

What else can I try to get this to work? For me, FF 3.6.10

share|improve this answer
    
try running firefox in safe mode, or switching to Chrome -- it's better than Firefox anyway! –  Jeff Atwood Sep 24 '10 at 4:28
1  
@Jeff: why can't we close comments as subjective? :p –  Tobias Kienzler Oct 15 '10 at 12:56
add comment

Well - I jumped over to IE to type in this answer. I was original in FireFox 3.5. I have NoScript installed, but have checked the option that says "Scripts Globally Allowed (dangerous)" (which in my opinion is not really dangerous).

I'm doing work with Dojo - and JavaScript in all my applications that I'm writing, so I really don't think JavaScript is off.

I also have Firebug installed in Firefox.

Here in IE - the "Your Answer" box appears and I can type in without clicking anything. In Firefox - I click "Answer your question" and nothing happens.

Neal

NOTE: See my new answer below for the "real solution".

share|improve this answer
5  
You need to allow javascript from sstatic.net –  Brad Gilbert Aug 28 '09 at 0:14
add comment
up vote 2 down vote accepted

Script was allowed - but the No-Script Plug-In was causing the problem.

I found the solution to the problem below was disabling No-Script http://stackoverflow.com/questions/1362444/dojo-is-not-defined-firefox-3-5-issue

then I confirmed that it was causing the Stackoverflow "Add Comment" problem as well.

Believe me - I had No-Script set to allow scripts from all sites, even though it said it was dangerous. Maybe No-Script hasn't fully adapted to Firefox 3.5.2 yet?

share|improve this answer
add comment

You should note that you need 50 points to add comments. Your account here on Meta only has 1 and the account on SO has 11. That said, if you don't see a pop-up that alerts you to this restriction, I point you to Chacha102's response.

share|improve this answer
    
The OP said that this was a comment to one of his own questions, so the rep limit shouldn't apply. You're right in general, though. –  Pops Sep 27 '10 at 19:03
add comment

Yes, this site is very non-traditional. In fact, most people would not call it a forum at all.

To perform many actions, you must have JavaScript enabled, that's probably the problem you're having with adding a comment (as Chacha102 indicated).

To answer your own question, you should wait 24 hours. However, please don't do that to respond to others on your question. Use comments for that. Answer your own question only if you genuinely have found a solution on your own that you wish to share.

share|improve this answer
add comment

Do you have Javascript Disabled?

A lot of animations like showing the comment form run on jQuery, a popular javascript library, that doesn't work well if you don't have javascript enabled.

Well... it doesn't run 'at all' if you don't have Javascript enabled.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .