What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

It seems that if I edit a question and an answer on the same question, I only get credit for one edit.

Is this a known issue? By design? The only potential duplicate I've spotted was this one, but that deals with multiple edits to the same post, not multiple edits on the same page.

In my revisions tab on dba.SE, you can (at least I assume you can) see that I modified this question and this answer to that question.

Yet on users > editors, my edit count only increased once. You may say this is a caching thing, but I have waited several days in the past and observed the same behavior.

This related question used faulty queries on data.SE as the basis for their report that answer edits don't count, when in fact they do.

I will concede that these are not stellar examples of substantial / beneficial edits. But if this is by design, then it discourages - for anyone after Strunk & White / Copy Editor badges - cleaning up an entire set of question & answers, and quitting after editing only one or the other. In a lot of cases I've experienced, multiple posts on a single page can benefit from some editing...

share|improve this question

1 Answer 1

This looks like a bug on your side. I just ran some test and everything works fine for me.

Before editing:

enter image description here

I edit two posts on the same page

Question.
Answer.

After editing

enter image description here

share|improve this answer
1  
Thanks, I see that both edits counted on my badge progress mouseover (though that was a pain to find); however it is a different number than on Users / Editors and - while I have sometimes seen that page update immediately - it didn't update just now when I performed two more edits. (It is showing 11 more edits than the mouseover anyway; perhaps the bug is there somewhere.) –  Aaron Bertrand Jun 17 '13 at 17:02
    
@AaronBertrand Where do you find that users / editors count ? –  ʞunɥdɐpɐɥd Jun 17 '13 at 17:03
    
dba.stackexchange.com/users?tab=editors (adjust for your site) then switch to "all" (and filter for your username if you're not on the front page) - mine says 409 there while my badge progress mouseover says 398. Would be curious what yours says compared to the mouseover, and whether you observe updates immediately. The problem may simply reside outside the trilogy for whatever reason. –  Aaron Bertrand Jun 17 '13 at 17:05
    
@AaronBertrand Mine says 162. Which is kinda weird since it seems only 154 counted towards the badge. –  ʞunɥdɐpɐɥd Jun 17 '13 at 17:11
    
I guess the badge progress count excludes some trivial edits that are still counted on the user page, so perhaps one of my edits was considered trivial. –  Aaron Bertrand Jun 17 '13 at 17:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .