What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

In the /badges page for a logged-in user, there is a green check beside each badge that the user has obtained. This check is the unicode symbol &#10004, but for many users that will display as a block. This is the case on a default English Windows XP install (I think because Arial Unicode isn't there by default), which I imagine covers a huge part of your audience.

It would be better if you just used an image.


Here is a screenshot:

share|improve this question
2  
I see this all the time and I always forget how to fix it. So the question should actually be "How do I corrected my configuration to properly display perfectly valid web pages?" –  Robert Cartaino Jul 2 '09 at 15:35
    
i agree that it is perfectly valid page, in theory at least. but in practice, the set of users with a default windows xp install is probably pretty large, considering this is an english-only community. if the check were an actual text character in some language i would say "yeah, the user should update their configuration". but since it is an icon, i think using an image would actually be more appropriate. –  Kip Jul 2 '09 at 16:01
    
I noticed this myself as well. One of the computers I was on, or some browser, didn't display the check marks. –  Tom Ritter Jul 2 '09 at 16:01
    
@Kip. You're right. There doesn't seem to be a easily-accessible fix to this. I'm sure I could eventually hunt one down but the average user isn't going to do that. If anyone knows how to correct this, please post... –  Robert Cartaino Jul 2 '09 at 16:17
    
@rcar: you can fix it by going to control panel/regional and language options. under "languages" tab, check the "install files for complex script" and "install files for east asian languages" boxes and click OK (you'll need your XP CD probably). then the checks show up fine. i think the checks show up as a side-effect of unicode fonts being installed (though not arial unicode, as i had thought). –  Kip Jul 2 '09 at 20:55
    
@Kip: That worked but I had to check off "Install Files for East Asian Languages." Got my checks now. –  Robert Cartaino Jul 3 '09 at 19:07
    
Anyone have a fix for when most browsers work, but Chrome shows a square? –  Nosredna Jul 26 '09 at 20:31
    
Oh, great... now it's an image. –  Shog9 Aug 16 '09 at 3:57

1 Answer 1

up vote 1 down vote accepted

This can be corrected (in IE at least) by going to Tools > Internet Options > "General" tab > Fonts and select "Arial Unicode MS" as the default font.

share|improve this answer
    
arial unicode MS isn't included on a default english windows xp install. i think the "support for east asian languages" option must be enabled (not sure) –  Kip Jul 2 '09 at 15:56
    
I dunno - it was available on mine, but I've also got Office, etc. so I can't point to a specific source or time frame that it was installed... –  GalacticCowboy Jul 2 '09 at 16:31
    
According to Microsoft, the Microsoft Arial MS font is installed with MS Office. It used to be available free on the MS site free, but no longer. As far as I can surmise, that is the root of the problem. Maybe somebody here knows better. –  Robert Cartaino Jul 2 '09 at 17:04
    
According to blogs.msdn.com/michkap/archive/2007/07/15/3890144.aspx (as noted in the comments of superuser.com/questions/52671/…), using Arial Unicode MS does more harm than it solves. It even suggests deleting the font. I'm not on Windows so cannot check. –  Arjan Mar 26 '10 at 6:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .