What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

On Stack Overflow, I logged in just now and noticed my gravatar was changed to my Facebook picture (using Firefox). I never changed it myself and thought it was strange, so I changed it back. After that, I launched Google Chrome and logged in again from there, and my facebook Picture was there again instead of the Gravatar. I have no idea why this is happening, but wanted to report it here.

share|improve this question
    
I assume you mean on Stack Overflow? –  FDinoff Jul 1 '13 at 21:41
    
@FDinoff: Yes, edited. –  Jesse Good Jul 1 '13 at 21:41
    
Did you login with facebook? Also you appear to not have a gravatar - that's why we're using the facebook one...we didn't consider this case though, hang on. –  Nick Craver Jul 1 '13 at 21:42
    
@NickCraver: Yes, I clicked on log in and then clicked the Facebook icon. I can change back to my old gravatar from my user screen, what do you mean no gravatar? –  Jesse Good Jul 1 '13 at 21:43
    
I can repo this (on Stack Overflow) simply by logging out, and logging in (with Facebook), even though I have a Gravatar which I've been using for years. –  Matt Jul 1 '13 at 21:44
    
@JesseGood can you reproduce this now? –  Nick Craver Jul 1 '13 at 22:10
    
@Matt can you retry now please? –  Nick Craver Jul 1 '13 at 22:11
    
@NickCraver: It appears to be fixed. Thank you for the quick response. –  Jesse Good Jul 1 '13 at 22:24
    
@JesseGood awesome, thanks for the confirmation :) –  Nick Craver Jul 1 '13 at 22:26

1 Answer 1

up vote 7 down vote accepted

We intended to do this for Facebook users only when they first login (as facebook.stackoverflow.com did) - that logic wasn't correct. A build is rolling out now to ensure it only happens on user creation (not every time you login). You can unset/change it once in your profile if you don't want it, and it'll stick once the profile (since it won't even try to set it again).

A build is rolling out now that will behave correctly - give it a few minutes.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .