What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

I originally tried to update the issue that is described here, which I'm also having. Unfortunately that edit got rejected, so I guess I have to write my own question.

When I try to log in to Stack Overflow on my newly installed Windows 8 machine, nothing happens. I can click on the OpenID provider buttons, but the page is not redirected. In the background, a JavaScript exception occurs.

The issue is being caused because a JavaScript tries to access window.localStorage, but this raises an exception:

openid-jquery.js, line 9 character 73
SCRIPT5: Access is denied.

Most likely, an exception when trying to access this property should be treated as if local storage is not supported by the browser at all.

What is causing the access to be denied, seems to be the Protected Mode option in the browser options. This is enabled by default on my system:

Protected Mode option in IE

If this doesn't give a sufficient repro case, the problem might be reproduced like this, however this is not what is happening on my system. Process Monitor does not show any failing file access, and Enhanced Protected Mode is not enabled.

Obviously, I do not run my browser as Administrator by default (nor do I want to), but doing so would allow the login, regardless of this checkbox.

I also have another Windows 8 machine at home, for which it works out of the box. On my work Win8 Enterprise machine (on which I did not enable compatibility view), it does not.

share|improve this question

marked as duplicate by Makoto, Rob W, hims056, Shadow Wizard, ben is uǝq backwards Jul 4 '13 at 20:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Compatibility mode should be disabled. –  Makoto Jul 4 '13 at 16:37
    
@Makato: that's silly. A simple change would support a main stream browser without users changing settings. Hell, a <meta> tag can be added to the HTML to disable compatibility mode. –  Thorarin Jul 4 '13 at 16:38
    
@RobW: not a duplicate, because it gives no usable fix, nor does it accurately describe the problem. User intervention in the form of changing browser settings shouldn't even be needed on any self-respecting website. –  Thorarin Jul 4 '13 at 16:44
    
I disagree; it's up to the site maintainers to determine what browsers they wish to support, and how they wish to support it. Here, SO expects that compatibility mode is disabled on your end; if it isn't, then undefined behavior can occur and they don't elect to support it. Besides, who's to say that this <meta> tag won't have side effects with other, well-supported browsers? –  Makoto Jul 4 '13 at 16:45
    
@Makato even if it had side effects, it's easy to add it only for IE browsers. Now you're forcing users to enable or disable compatibility mode depending on which sites they are visiting. Plus you're not supporting the default browser with default settings on the most current Windows OS. That's just plain dumb. –  Thorarin Jul 4 '13 at 16:49
    
@Thorarin - Curious, I cannot repro this. I am able to log into SE on my Windows 8 Pro desktop, as well as my Windows 8 RT Surface device. Protected mode is enabled on both. –  chue x Jul 4 '13 at 17:08
    
@Makoto "We support current and previous versions of all browsers with some reasonable amount of market share" And what do you think IE10 is exactly? The rest of what you say is nonsense, too. –  Grant Thomas Jul 4 '13 at 17:58
    
So...all of this to say that you refuse to disable compatibility mode so that SO will work for you? While I think this is getting rapidly out of hand, IE10 doesn't have that much market share. They also explicitly state that you need to have compatibility mode disabled when using this browser. If you don't want to do that, be prepared to accept general breakage or degraded performance. –  Makoto Jul 4 '13 at 18:25
    
@chuex Of course there is the possibility that I'm missing some variable in the equation. I just noticed that either Administrator privileges or disabling "protected mode" have an effect. On my home Windows 8, it works. At work on Win8 Enterprise in a domain, it errors. –  Thorarin Jul 4 '13 at 19:39
    
@Thorarin - I normally do not run IE with admin privileges. It would be crazy to do from a security perspective. –  chue x Jul 5 '13 at 0:40
add comment

Browse other questions tagged .