What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

I'm aware of the couple "searching for a wildcard tag gives you a blank page" bug reports here, but wanted to report that if you search for a wildcard tag, it now works, BUT if you try to add a second tag to that search, it fails miserably with a proper (non-blank) 400 error. This is particularly bad, given that you explicitly link to the pages that give the 400 error after a search for a wildcard tag.

To reproduce, merely click any of the "related tags" links below:

hxxp://stackoverflow.com/questions/tagged/python~

(and for some reason, the system won't auto-link that, and it thinks that my htmlifying of it means I'm posting two hyperlinks)

share|improve this question
    
Just ran into the same problem with... stackoverflow.com/questions/tagged/java~ Kind of surprised by Jeff Atwood's answer to this one. It's clearly broken, the application served the broken link. That seems strange to be "by design". –  delux247 Oct 15 '09 at 3:23
    
Yeah I agree. It's an incorrect design, however intentional it may or may not be. "It's a feature, not a bug!" –  Paul McMillan Oct 16 '09 at 6:04
add comment

1 Answer

Url too long; this is by design. Delete some tags or be more narrow in your wildcards.

Did you seriously expect to put 50+ tags in the URL and have it work?

share|improve this answer
2  
No, but you shouldn't have created links that were to long (did you seriously expect to put 50+ tags in the URL and have it work?) –  deleted Aug 29 '09 at 20:05
3  
Uh, yeah... this answer would make more sense if the system wasn't generating the broken URLs. –  Shog9 Aug 29 '09 at 21:11
    
users are generating broken wildcard searches. Python~ is too broad. –  Jeff Atwood Aug 30 '09 at 12:12
5  
The system should then return a polite "be more specific" response. A broken link in the UI is NEVER ok if it was reached by using the UI as intended. –  Paul McMillan Aug 30 '09 at 14:50
2  
The system returns 400 errors by design? That seems... technically incorrect at best... –  Gabriel Hurley Sep 11 '09 at 10:58
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .