What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

My MyOpenID login is working right in Ask Ubuntu, but I can't log in to Stack Overflow or Meta Stack Overflow using MyOpenID, Google nor Stack Exchange. The only page I see is the "Oops! Something Bad Happened!" one.

If I try to create an new Stack Exchange account using my email, it says this email is already registered. If I try to recover my account, it says:

Someone requested an account recovery on Stack Overflow for myemailaddress@gmail.com, but we don’t have an account on this site that matches this email address.

But you have an account on these other sites:

Stack Overflow

Ask Ubuntu

It makes no sense.

I've already tried to change browser and turn on cookies, as said here: Can't log in with my OpenID - Troubleshooting Tips But my MyOpenID is working in Ask Ubuntu.

My user is: http://stackexchange.com/users/1474753/yuric

share|improve this question
    
Strange... Magically now I'm able to login with MyOpenID and with Stack Exchange account to Meta StackoverFlow. But not to StackoverFlow ("Oops! Something Bad Happened!" page, as usual)... Unfortunately, I can't figure out why this is working out now. I'm using one of the same browsers I've used before for testing... –  YuriC Aug 15 '13 at 2:41
    
    
Hmm. I didn't know this. Thanks. Anyway, I still can't login to StackOverflow using my StackExchange account, nor using my Google account. But it works when logging in to Meta StackOverflow and AskUbuntu... –  YuriC Aug 15 '13 at 2:58

1 Answer 1

up vote 1 down vote accepted

Finally I'm logged in! Well, the solution came from something I've already tested: enabling cookies! (Can't log in with my OpenID - Troubleshooting Tips). In fact, the first time I tried it I had set a permission to stackoverflow.com to create cookies. But it was useless, because my default configuration is to let sites define cookies. But I set cookies to be delete every time Firefox closes and do not allow third-party cookies.

The different steps I took:

  • Cleaned Firefox's last hour cookies, cache, offline sites data and sites preferences.

  • I've set my Firefox browser to allow third-party cookies.

  • And I've restarted Firefox (But I don't know if this is strictly needed or not).

Since I could log in for the first time, I'm now able to login even if not allowing third-party cookies.

It was hard to imagine this error from a "Ooops" message... And I still can't figure out why it worked firstly for Meta Stack Overflow... It is fixed, anyway. Thanks you all.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .