Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 153 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I tried to post a comment on an answer and the app seemed to get stuck on the "Posting comment" popup. I tried to use the back button to cancel the posting so I could retry but pressing back did nothing, I had to manually force close the app. When I had reloaded the app the commenting worked as expected.

So the bug is perhaps the fact the commenting didn't work and got stuck, the feature request(s) would be a timeout so if it didn't work it could cancel and/or having the back button close the dialog.

share|improve this question
    
I think this is just a bug then. Implied in the reporting of the bug is the desire for something to be done to fix it. – Duncan Aug 16 '13 at 9:13
    
HTTP time out is must/necessary for all the web operation. – Paresh Mayani Aug 16 '13 at 9:13
    
@Duncan True! The timeout would be a fix but then perhaps the back button cancelling the dialogue would be a feature request, or I guess it could be seen as a fix if the timeout wasn't implemented. The team can always delete the feature-request tag if it's not considered appropriate. – Peanut Aug 16 '13 at 9:18
up vote 2 down vote accepted

This was due to the fact that comment posting was happening on the UI thread rather than in a background operation, so if it was taking a long time it'd freeze up the entire application. This has been fixed prior to version 1.0.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .