your communities

Today, on C.SE, I reviewed some 'Late Answers' and First Posts. I was not even near my daily vote limit. And yet, I was given a message that said

comments disabled on deleted / locked posts / reviews

It seems I was not the only one either: Why are comments now disabled on "first posts" reviews?

The workaround, of course, was simply to go back and provide the guidance - but was this a design or a bug? If it is design, why would you want to discourage the feedback? Especially with first posts, there is often a high percentage of 'didn't read the FAQ' usage, which can best be addressed by gently providing guidance. (e.g. "Unfortunately, this doesn't answer the question" or "This reads like a comment" or "This really isn't on-topic here - can I suggest you checkout our [faq]" etc...) Timely first post guidance goes a long way towards making good users.

If it was a bug, was other functionality silently rolled out?

share|improve this question
21  
You beat me to it. This seems very counter-productive. The odds of a first time user needing constructive, friendly guidance are quite high, compared to experienced users. Commenting and pointing to Meta posts is a valuable tool for those of us that want to help newcomers. I'm very curious about why this would be disabled. –  David Stratton Oct 1 '13 at 1:34
3  
Many, perhaps even most, first time OPs need help formulating & clarifying their question. This is a very unfortunate & counter-productive change. –  gung Oct 1 '13 at 1:43
3  
I am with you here. Did a first post review - and the answer was no where related to the question. I didn't know what to do, as the commenting was disabled. So, I simply down-voted the answer. And apparently, I failed the review. Sigh. –  NomadTraveler Oct 1 '13 at 1:46
2  
I've been opening the post in a new tab and commenting anyway. Very time-consuming, but I don't see any other way to actually be helpful. Hopefully this gets reversed quickly. –  David Stratton Oct 1 '13 at 1:48
2  
@Somya then it's a bad audit, and not because you were supposed to comment –  Jan Dvorak Oct 1 '13 at 1:51
4  
To (partially) address your closing question, comments disabled on deleted / locked posts / reviews suggests that this was a deliberate change (not a bug), since "reviews" seems unlikely to have ended up in that list by mere happenstance. Though why anyone would want to deliberately maim the review interface in that way is beyond me... –  Mac Oct 1 '13 at 1:59
1  
When did this change? –  jmac Oct 1 '13 at 2:00
3  
Another example: in addition to flagging the answer, I almost always add a comment to link-only answers that asks the user to summarize the link's contents. I'm not sure why such behavior is intentionally discouraged, especially since link-only answers themselves are discouraged, and I've been led to believe that comments asking for a summary are welcome. –  John Bensin Oct 1 '13 at 2:07
    
@JanDvorak - What other option did I have? Get rid of the answer. But that would mean posting a blank answer :P –  NomadTraveler Oct 1 '13 at 2:22
4  
this looks like (a pretty lame imNSho) attempt to salvage "known good" audits in this queue, which fail miserably if one can comment. Next (lame) steps will likely be disabling flagging and edits, thus making whole review a victim of wrongly picked audit strategy. Why doesn't SE team consider keeping only "known bad" audits in FP / LA queues, simply escapes my mind –  gnat Oct 1 '13 at 7:26
7  
Just went through a dozen reviews. Do not like this. At all. Cannot explain in a comment why you are voting to close. Cannot explain to a new user where to look for pointers to improve their posts. Cannot explain to late answers that their answer is a complete duplicate of another answer. What a horrible design choice. –  jmac Oct 1 '13 at 8:43
7  
Judging by Shog's edit, it looks like this is a bug and not an intentional change. Hopefully someone from the dev or community team can chime in and let us know the status –  psubsee2003 Oct 1 '13 at 10:03
5  
@gnat let's not get carried away. It's a bug. –  Ben Collins Oct 1 '13 at 13:16
4  
@BenCollins it's rarely that I am glad to hear that something is a bug, but in this case, I really am –  gnat Oct 1 '13 at 13:19
3  
Looks like it's now fixed. Thank you! –  David Stratton Oct 2 '13 at 5:43
show 8 more comments

1 Answer

up vote 12 down vote accepted

What happened here was that I set an incorrect flag on the review views which led to commenting being disabled in places where it shouldn't have been. This has been corrected now.

share|improve this answer
6  
So, I know common practice on MSO is to make snarky comments about our evil overlords and such - but every now and then you need to hear it plain. We who use your work every day really, really appreciate the hard work that goes into making this one of the best dang places on the Internet. Thank you for your service. –  Affable Geek Oct 2 '13 at 19:21
    
This bug on Maths.SE seems intimately related. I can confirm that the issue has gone away on duplicate reviews (in the duplicate tab); however, it still occurs on "first post" reviews (below the question), and possibly also on "low quality" reviews. Thanks for looking into it. –  Lord_Farin Oct 3 '13 at 14:31
    
@Lord_Farin Can you provide a link to a specific review exhibiting this problem? –  Ben Collins Oct 3 '13 at 14:33
    
This one. Click "show 6 more comments" to show the dreaded text. This one from the Low Quality queue originally instigated my post. –  Lord_Farin Oct 3 '13 at 14:39
1  
Ah. In both cases, the behavior is correct, but the text is not. The correct text would be something like "disabled for review". This will be fixed soon in a build near you. –  Ben Collins Oct 3 '13 at 14:56
    
@BenCollins Excellent; when the appropriate time comes, could you be as kind as to answer the question on meta.maths.SE and mark it status-completed? Thanks for your time. :) –  Lord_Farin Oct 3 '13 at 14:59
    
(Sorry to bother you again, but it turns out my report of success for duplicate reviews was pre-emptive -- I have encountered it again today, but it doesn't show up when visiting the review page afterwards.) –  Lord_Farin Oct 3 '13 at 17:24
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .