What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I'm consistently receiving significant delays on Stack Overflow when opening the flag dialog on questions. Delays do not occur on any other StackExchange site I have checked. This started a couple days ago (as far as I can tell).

Delays occur not only when loading the initial screen, but also when loading the submenus. This is slightly confusing for a couple seconds (until you're used to it) since it appears as if the flag dialog has simply vanished.

What's going on here? I demand to know, otherwise somebody will be very upset.

Not me. I'm not going to get that upset over something like this.

But someone will.


Specs (though I know of several others who have this issue):

Windows 7 64-bit
Chrome Version 30.0.1599.69m
    Ping: 31ms
Download: 6.88mbps
  Upload: 1.07mbps
share|improve this question
7  
For me, there's a long delay when flagging questions, but no delay when flagging answers. –  Pang Oct 7 '13 at 1:04
    
@Pang Good point. I've edited the question. –  Emrakul Oct 7 '13 at 1:06
3  
Same for me. Started a few days ago, can't remember exactly when. –  Szymon Oct 7 '13 at 1:41
1  
I'm glad to know it's not you who would be upset... ;-) –  Andrew's a Unitato Oct 7 '13 at 1:42
1  
I just tested, and noticed it as well (for questions; don't know about answers). Here's a screenshot of the request timings for the initial screen, and for the "it should be closed for another reason..." submenu. –  Nightfirecat Oct 7 '13 at 2:59
    
Answer flagging seems pretty speedy, I think its just question flagging (and only on the main site for me, not meta) –  Richard Tingle Oct 8 '13 at 14:37
    
I also experience the same problem when closing a question. Here is a screenshot of Chrome's dev console showing 6 seconds for loading a JS file! –  ComFreek Oct 8 '13 at 14:38
add comment

1 Answer 1

up vote 18 down vote accepted

Some backend changes to get closing and flag dialogs into a more declarative version (in preparation for adding them to the android app) ended up causing a couple of rather expensive queries to run when they didn't use to.

This was fixed over the last couple deploys, flagging and closing should be pretty much the same speed they were before the refactoring.

share|improve this answer
1  
This one should also be marked completed. –  Shadow Wizard Oct 8 '13 at 21:34
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .