What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

Currently I am posting this on a page without any CSS style. Anyone else experiencing this?

I am using Firefox 3.5.2 and have tried refreshing (CTRL + F5) multiple times, even closing the browser. I do have Stylish installed and was using it to create a Hot Dog Stand theme, but it was inactive when this happened.

Screenshot:

style-fail

share|improve this question
2  
Yes. I blame it on my crappy VPN. –  Shogging through the snow Sep 3 '09 at 20:38
    
How did sheep get into this conversation? –  John Fouhy Sep 3 '09 at 22:27

4 Answers 4

up vote 12 down vote accepted

You're hitting the dynamic IP restriction throttle limits on sstatic.net -- too many requests for static resources in a given (n) second period.

This can be caused by some greasemonkey scripts, and I know of one serious Firefox bug that can cause it to happen. But in typical use, it shouldn't happen.

share|improve this answer
    
Though I see if from time to time, it only ever occurs on Firefox. –  akf Sep 3 '09 at 21:55
    
that Firefox bug is a BASTARD. It causes every single static resource on the page to force-reload, and every instance of every resource to load. It's really bad. –  Jeff Atwood Sep 3 '09 at 23:38
    
Bugzilla #? –  Shogging through the snow Sep 3 '09 at 23:48
1  
no idea, it's not my job to fix Firefox. But we have verified the bug, and that it's specific to Firefox. Results in a hailstorm of 100+ requests to the server. –  Jeff Atwood Sep 26 '09 at 9:10
    
At least it's not Opera this time. –  random Sep 26 '09 at 9:13
    
I've seen this happen occasionally with IE7 but never with Firefox. –  mmyers Oct 27 '09 at 16:19
    
@Jeff ATwood THANK YOU for letting me know about this Firefox bug; I couldn't reproduce it reliably, but the same thing would happen to me; although I was having instances where JavaScript wouldn't load. –  George Stocker Oct 27 '09 at 18:36

When it happens next, check the status of Firebug and check to see if the download of the CSS file failed somehow.

share|improve this answer

Our proxy eats css files sometimes. Or, more technically, something dies in the request chain. Refresh nearly always fixes it.

share|improve this answer

I have before, but it was fixed with a refresh. Not sure what caused it though.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .