What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

This question already has an answer here:

I can't see the Web page displaying properly. I have been trying to access it since morning but unable to do so because it's not displaying the web page properly. Yes, Meta Stackoverflow is working fine. I'm not even able to login into Stackoverflow.

Browser I'm using: Firefox Latest version on Windows 7 Professional

Attaching the Image of stackoverflow :enter image description here

share|improve this question

marked as duplicate by hims056, Richard Tingle, Aziz Shaikh, Shadow Wizard, Hugo Dozois Oct 15 '13 at 13:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

7  
And Meta-SO is working perfectly? –  hjpotter92 Oct 14 '13 at 22:37
4  
@hjpotter92 I think MSO runs on a different circuit, so to speak - I've seen an answer where a staff member alludes to MSO not using the CDN for resources and stuff. –  michaelb958 Oct 14 '13 at 22:47
4  
If your internet is having issues it can drop packets - specifically the ones where your browser was fetching the css for the site. I have seen this occur during times of my internet running poorly. –  Travis J Oct 14 '13 at 23:12
    
I have added some details. I hope it clarifies most of you people questions. Let me know if more information is needed. –  Tan Oct 14 '13 at 23:13
3  
@Tan "latest version" is meaningless. Please provide the specific version #. –  psubsee2003 Oct 14 '13 at 23:23
    
Firefox Version : 21.0 . Does this makes sense? –  Tan Oct 14 '13 at 23:38
1  
@TravisJ +1 this happens often to me, the CSS just fails to load and you're left with a raw page. Usually comes from poorly routed CDN's, but it also happens with bad internet (especially over wifi). –  Thomas Oct 14 '13 at 23:38
    
Hmm, But I'm not using Wifi at my work place. Perhaps a bad connection is the only main cause –  Tan Oct 14 '13 at 23:39
1  
@Tan Firefox tends to upgrade frequently, but I believe Firefox us up to v24 at the moment. V21 is at least 3 months old. You might want to check that you are indeed up to date. Typical SO only supports the current and previous 2 versions. You might be out of date. (not saying this is the problem, just that the browser might no longer be officially supported) –  psubsee2003 Oct 14 '13 at 23:45
3  
Use the dev tools of your choice (e.g. Firebug in FF) and look at network activity when the page is loaded. Chances are, one or more resources is not making it to your machine. This can be for a variety of reasons, nearly all of which are out of SO's control. –  Tim Medora Oct 14 '13 at 23:47
5  
It's the new "cragislist" skin. You don't like it? –  Wesley Murch Oct 15 '13 at 0:44
    
@WesleyMurch Haha, Nice one. I didn't like it :) –  Tan Oct 15 '13 at 5:36

2 Answers 2

up vote 5 down vote accepted

This happens from time to time. Usually, several refreshes will clear it.

If that doesn't work, clear your cache and try again.

Works for me.

share|improve this answer
1  
do CTRL + F5 to refresh –  user221081 Oct 15 '13 at 11:53

It may not be the problem with Meta Stack Overflow, it is just a basic problem with your internet or browser while trying yo connect with Meta Stack Overflow and this is the reason why as Emrakul's suggestion (Usually, several refreshes will clear it. If that doesn't work, clear your cache and try again.) work out.

When the webpage is refreshed the request is send once again and it rectifies the problem.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .