What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

It seems that the inbox on MSO still isn't refreshing properly. I believe the initial pains are supposed to be fixed, but it's difficult to see in the huge feedback thread, so I'm reporting this separately.

I had a tab open on MSO and another tab open on another SE site. Someone commented on one of my posts, and I saw a notification appear (red ①) in the inbox on both sites. I decided to open the MSO inbox, probably less than a minute after the notification appeared. When I clicked, the list of replies did not include the one that triggered the notification: the latest reply in the inbox as it appeared on MSO was my then next-to-last reply dating from a couple of hours ago. When I opened the inbox on the other SE site, I saw my latest reply as I should have. After refreshing the MSO tab, the inbox showed my latest reply.

This doesn't happen all the time: I've also observed the inbox to refresh properly. So far, my observations are consistent with the following:
With the new top bar, if I've already viewed my inbox in a tab, then when a new notification comes in, the red ① is displayed as expected, but the list of messages displayed by the inbox is not updated.

Google Chrome 30.0.1599.114 if it matters.

The same bug has been observed with the achievements list.

share|improve this question
    
Cannot reproduce on Internet Explorer 11 on Windows 7. –  user215114 Nov 19 '13 at 23:07
    
@gparyani I can reproduce (still in Chrome): I had an MSO tab open, and my inbox in that tab isn't showing your comment. This isn't systematic. I suspect that this only happens if I've already accessed the inbox in that tab. –  Gilles Nov 19 '13 at 23:12
    
Why don't you upgrade to Chrome 31? –  user215114 Nov 19 '13 at 23:13
6  
@gparyani Chrome 31 is out? Oh, it came out last week. I think my Chrome process has been running for longer than that. I'm not an upgrade freak, I'm content with software that's more than a week old… Why should I waste time upgrading all the time? I wish there was a stable version of Chrome and Firefox! –  Gilles Nov 19 '13 at 23:22
    
I noticed this too several times, but wasn't able to reproduce. Hopefully they're still working on the whole thing and fix that before it's spread across the network. –  Shadow Wizard Nov 19 '13 at 23:36
    
I saw this happen earlier as well. There was nothing there, but when I clicked it, the notification showed and then immediately disappeared. I was using Chrome Version 31.0.1650.57 m –  Travis J Nov 19 '13 at 23:36
    
As for Chrome, just close it once a day and make sure to tick "Continue where I left off" in the settings - next time you open it you won't lose anything and get auto updates this way. –  Shadow Wizard Nov 19 '13 at 23:41
2  
@ShaWizDowArd “Close it once a day”??? Why on earth would I do that? I do have Chrome configured to save tabs, but that doesn't save everything (scroll positions, window placement, everyting incognito, …). Also I don't use auto updates, no software gets the privilege to break behind my back. I use the Ubuntu packages and run apt-get upgrade when I feel like it. –  Gilles Nov 19 '13 at 23:45
    
@Gilles can't judge you, but Chrome is fast to update, and sometimes they're doing breaking changes. Anyway on this specific issue it doesn't matter, it's most likely server side issue. :-) –  Shadow Wizard Nov 19 '13 at 23:46
3  
@ShaWizDowArd Breaking changes are a reason not to update. –  Gilles Nov 20 '13 at 0:06
    
I certainly see this with Chrome 31 on Mac. Leave a page open, load the inbox when a message comes in. Any new messages after that won't show in the dropdown as it is not reloaded for new messages. The same applies to the achievements dropdown and green rep delta, only worse as the rep delta doesn't reset properly. –  Martijn Pieters Nov 20 '13 at 13:28
add comment

1 Answer

up vote 1 down vote accepted

This was fixed before the top bar rolled out as part of a large refactor of how the whole thing worked client-side. Apologies on the delay updating all the questions related to topbar bugs, trying to clean up now.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .