What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I'm very much interested to answer questions on Stack Overflow but everytime I try to answer, the answer can not be posted because of the SQL.

It simply returns "An Error occurred submitting the answer/edit", there is no further explanation.

I used proper quotes and interestingly enough if I upload code up to the where clause it works perfectly, but if I include the where clause posting the answer will fail.

This is the code that is problematic:

col column_name FOR a30 
SELECT d.owner, 
       d.table_name, 
       c.constraint_name, 
       d.column_name, 
       c.constraint_type 
FROM   dba_constraints c, 
       dba_cons_columns d 
WHERE  c.table_name = '&TABLE_NAME' 
       AND c.owner = '&SCHEMA_NAME' 
       AND c.constraint_name = d.constraint_name 
share|improve this question

migrated from stackoverflow.com Dec 5 '13 at 13:08

This question came from our site for professional and enthusiast programmers.

    
I tried to upload my query but it wont allow me, –  Harry Dec 4 '13 at 15:28
    
Thanks Luke, Yes problem is with STack overflow itself. I will upload the code to gist.github.com, I never used "gist.github.com" let me check it . Once I upload the code there. I will let you know –  Harry Dec 5 '13 at 11:39
    
Hi Luke, Here is the link for query. As I said I can upload the SQL query upto WHERE clause without any problem, once I use where conditions it fail. gist.github.com/anonymous/dbd6abee3598c3e46432 –  Harry Dec 5 '13 at 11:47
    
Are you sure that you put it inside code tags properly? –  Shadow Wizard Dec 5 '13 at 13:27
    
Works for me...I can post it without problems. Most likely an addon of your browser that does interfere with it. –  Time Traveling Bobby Dec 5 '13 at 13:29
    
@TimeTravelingBobby as noted by ShaWizDowArd here: Keep in mind that on Stack Overflow there is server side quality filter which is turned off here on Meta. –  Stijn Dec 5 '13 at 13:30
1  
@Stijn: I tried it on Stack Overflow (on a soon-to-be-deleted-question). –  Time Traveling Bobby Dec 5 '13 at 13:46
    
@httime-traveling-bobby Was it successfully in Stack Overflow? –  Harry Dec 5 '13 at 15:59

You must log in to answer this question.

Browse other questions tagged .