What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 150 Stack Exchange communities.

On approving an edit, I just get this pop up since morning. At first I thought there might be some internet connection issue, but this is now the 3rd to 4th time I got the same error; also, the review is accepted because on refresh I can see my name with approved text beside, but it still throws this error.

enter image description here

I am on a Windows 7 machine, running Firefox 24 (Icognito/Private Mode)


Also, this happens only when edit(1) is written on an question/answer, I don't go to review queue and approve, these reviews were directly loaded from the notification beneath the question/answer.

Martijn Pieters reproduced the problem from the review queue three times; each time the improve option was picked, accepting the suggested edit but editing the post some more. The network console shows that posting to http://stackoverflow.com/review/task-reviewed fails, the server responds with a 404 error:

Request headers:
POST /review/task-reviewed HTTP/1.1
Host: stackoverflow.com
Connection: keep-alive
Content-Length: 137
Accept: application/json, text/javascript, */*; q=0.01
Origin: http://stackoverflow.com
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36
Content-Type: application/x-www-form-urlencoded
DNT: 1
Referer: http://stackoverflow.com/review/suggested-edits/3575396
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en,en-US;q=0.8,nl;q=0.6,nb;q=0.4,no;q=0.2,de;q=0.2,fr;q=0.2
Cookie: <redacted>

POST data:
taskTypeId=1&reviewTaskId=3575396&taskResultTypeId=5&fkey=f8791a329b445b658876f4d3afe7961e&postCommentId=null&taskResultSubtypeFlags=null

Response headers:
HTTP/1.1 404 Not Found
Cache-Control: private
Pragma: no-cache
Content-Type: application/json
X-Frame-Options: SAMEORIGIN
Date: Fri, 13 Dec 2013 12:04:53 GMT
Content-Length: 0

On the suggested edit page itself, no record is made of the accept; instead the suggested edit is recorded as approved by 3 people not including Martijn Pieters. In this case the improve review arrived too late.

In another suggested edit review, improve again resulted in the error, but the Community account is shown rejecting the edit.

share|improve this question
    
Any messages in the console? (usually listed under developer tools). –  Martijn Pieters Dec 13 '13 at 11:54
    
@MartijnPieters I just shared before you commented :) Edit: Well, didn't see that, but I will just keep a check on that next time –  Mr. Alien Dec 13 '13 at 11:55
1  
Reproduced on Mac OS X and Chrome. –  Martijn Pieters Dec 13 '13 at 11:57
1  
The UI is stuck at the loading next item stage, the console states: Failed to load resource: the server responded with a status of 404 (Not Found) for http://stackoverflow.com/review/task-reviewed. –  Martijn Pieters Dec 13 '13 at 11:58
    
I'll see if I can trigger it again to inspect the network tab. –  Martijn Pieters Dec 13 '13 at 11:58
    
@MartijnPieters exactly, nothing happens thereafter, it keeps on loading, unless and until f5 is pressed, and than I see it again, wolaaa, review is approved –  Mr. Alien Dec 13 '13 at 12:01
    
For what it is worth: I picked improve in that case. This may be relevant because improving kicks the edit out of the queue. –  Martijn Pieters Dec 13 '13 at 12:04
    
@MartijnPieters Didn't tested that.. I either approved or rejected, seems like review is recorded but the redirection fails as you already got 404 –  Mr. Alien Dec 13 '13 at 12:05
    
Bingo, another improve (accepting the suggested edit but adding my own) reproduced the problem again. I'll edit your bug report to add details. –  Martijn Pieters Dec 13 '13 at 12:05
    
@MartijnPieters I would really appreciate that :) –  Mr. Alien Dec 13 '13 at 12:06
    
I don't think it is exclusive to improving the suggested edit; it looks as if the edit was approved before my vote was recorded. Thus your suggested edit vote arrives too late and the suggested edit is already taken out of the queue. The 404 error is not helpful or properly handled here. –  Martijn Pieters Dec 13 '13 at 12:15
    
@MartijnPieters May be that's the scenario that already 3 edit votes are casted, but again, where I had approved, I was either 1st or 2nd one to vote that.. so may be there's some other issue here, probably redirection to the next post –  Mr. Alien Dec 13 '13 at 12:17
    
No, it is clearly the POST to task-reviewed that fails here; 404 means 'not found'. It is not the redirect to the next post that fails. –  Martijn Pieters Dec 13 '13 at 12:18
    
@MartijnPieters ummmmm, may be, lets wait for the SO staff to see what's the real issue... –  Mr. Alien Dec 13 '13 at 12:19
    
Just reproduced it again by improving; this time I unchecked the 'suggested edit was helpful' box. It failed again, it there was only one other reviewer: stackoverflow.com/review/suggested-edits/3575511. That invalidates my first hypothesis. –  Martijn Pieters Dec 13 '13 at 12:24

2 Answers 2

up vote 5 down vote accepted

This should now be fixed. Suggested edits in particular had another code path approving the suggested edit before hitting the new validation logic. This removed the edit you just improved from the valid review tasks... since you just completed it.

A few tweaks to race conditions went out earlier around this, and another set will be deployed in a build today for Close and Low Quality queues around their race conditions as well.

share|improve this answer

My observations:

  • I can reliably trigger the error when using Improve. 3 out of 3 reviews where I picked improve failed. It doesn't matter if I leave the Suggested edit was helpful box checked.
  • The review is not recorded in the suggested edit review history or my review activity. The other reviews I made today all show up there, not the 3 failed reviews. I can bypass the review vote limits this way, I suspect.
  • It doesn't matter how many other people have reviewed the edit; my most recent review had only been reviewed by one other person.
  • The edit I make is recorded correctly and listed in the post history. However, on the post itself the suggested edit author is posted as last editor.

    See this post, where the revision history shows I removed the salutation, but the post itself is shown as edited by Aperçu.

    Then again, for the post where I rejected the suggested edit as not helpful, I am listed as the most recent editor.

  • The review counts; the review is either approved or rejected. Suggested edit statistics for the person making the suggestion are updated.

The failure is caused by the server returning a 404 response; POSTING to http://stackoverflow.com/review/task-reviewed fails:

Request headers:
POST /review/task-reviewed HTTP/1.1
Host: stackoverflow.com
Connection: keep-alive
Content-Length: 137
Accept: application/json, text/javascript, */*; q=0.01
Origin: http://stackoverflow.com
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36
Content-Type: application/x-www-form-urlencoded
DNT: 1
Referer: http://stackoverflow.com/review/suggested-edits/3575396
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en,en-US;q=0.8,nl;q=0.6,nb;q=0.4,no;q=0.2,de;q=0.2,fr;q=0.2
Cookie: <redacted>

POST data:
taskTypeId=1&reviewTaskId=3575396&taskResultTypeId=5&fkey=f8791a329b445b658876f4d3afe7961e&postCommentId=null&taskResultSubtypeFlags=null

Response headers:
HTTP/1.1 404 Not Found
Cache-Control: private
Pragma: no-cache
Content-Type: application/json
X-Frame-Options: SAMEORIGIN
Date: Fri, 13 Dec 2013 12:04:53 GMT
Content-Length: 0

The specific suggested edits on which this happened:

share|improve this answer
    
Thanks for the specific reports, can you reproduce this issue anymore? Suggested edits had another code path that affected things (it had been approved/rejected/edited and was no longer reviewable when validation logic was checking it). I'm seeing a similar path in LowQuality post review queues for close votes due to races, another fix is headed out there in a bit. –  Nick Craver Dec 13 '13 at 16:31
    
@NickCraver: Improving suggested edits appears to be are working again! Thanks. :-) –  Martijn Pieters Dec 13 '13 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .