What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

In the Android app, when I perform a search that returns no results, there is no longer a message informing me no results were found. Instead it is just a blank white screen. It used to display the following message: No items to show... (the last image in this post shows what I'm talking about: Tag Search Not Returning Results in Android App). To reproduce this on the app:

  1. Select any of the sites from the left menu
  2. Search for some random gibberish that will not return any results in the Search Questions... box (for example one of my searches was "ghtyvb" on SO and another on Meta "scotch" didn't return any results, although I know neither of these are practical searches)
  3. Here I am used to seeing the message No items to show... but currently only seeing a blank white screen

I know the message displayed in a very similar scenario just the other day because I took a screenshot of it which you can see in the above linked post. Just wondering if anyone else is able to reproduce this right now? I believe having the message show when no results are returned is important because it verifies the search was completed. When I don't see a message it makes me wonder if I just hit the wrong key on my phone and closed the keyboard on accident.

I'm currently on version 0.1.78

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Thanks for catching this! I had broken this in refactoring the listviews in the app. I fixed it for version 0.1.79 coming out around midnight UTC.

Here's the intense diff:

--- SingleSiteQuestionsFragment.java    Mon Dec 30 15:00:09 2013 -0500
+++ SingleSiteQuestionsFragment.java    Mon Dec 30 17:29:51 2013 -0500
@@ -266,6 +266,7 @@

         @Override
         public void onHandled() {
+            super.onHandled();
             tellParentToUpdateActionBar();
         }
     }
share|improve this answer
1  
Last vote goes for you, sir! –  Shadow Wizard Dec 30 '13 at 22:32
    
@KasraRahjerdi you're welcome and as always, I'll mark it answered soon as I get the update. –  Brian Dec 30 '13 at 22:44
    
@KasraRahjerdi, this is happening again on 1.0.24 (reproduced the same way as the opening post). –  Howlin Mar 20 at 21:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .