What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I know comments are supposed to be second-class citizens, but I think the SE Android app developers have taken things too far this time.

When I tap the "n more comments" button below a question, the SE app closes ungracefully (for lack of a better term). What I mean is that the app disappears, and I am kicked back to the "Home screen" of my phone (where I launched the app from).

I do not get the option to send a bug report, nor does the app attempt to restart. This one is consistently repeatable for me.

When I tap the "n more comments" button below an answer, the app only closes sometimes (I can't seem to find a pattern), and I usually (always?) get the option to send a bug report*.

Stop the tyranny. Stop the censoring. Let us have (all of) our comments.

**I may or may not have sent a bunch of these reports with a description of just "brown." Sorry about that. Love you, mean it.*


Addition info
Phone: DROID RAZR MAXX HD
Android version: 4.1.2
SE App version: 0.1.79

share|improve this question
    
I can't reproduce this on a Nexus S running 4.1.1 nor a Nexus 5 running 4.4.2. Is it happening consistently on all questions or just some? –  Kasra Rahjerdi Dec 31 '13 at 15:49
    
@KasraRahjerdi Its been happening for me for a long time, consistently on questions that I go to from notifications. –  AsheeshR Dec 31 '13 at 15:50
    
@KasraRahjerdi Weird! It's definitely happening on this question every time. (thanks for the quick reply, by the way. You comment-hating-despot, you) –  jadarnel27 Dec 31 '13 at 15:51
3  
There's some irony here that I'm discussing this via comments, I couldn't resist. –  Kasra Rahjerdi Dec 31 '13 at 15:52
1  
Their hate isn't new. –  AsheeshR Dec 31 '13 at 15:52
    
Maybe that phone got a special built in browser with different JavaScript engine? Can you try with Chrome or Firefox? :) –  Shadow Wizard Dec 31 '13 at 15:54
    
Ah I seem to not be able to reproduce it due to my insanely fast network connection, from the crash logs it looks like it's a race condition, I'll try to figure out what's going on thanks! –  Kasra Rahjerdi Dec 31 '13 at 15:54
2  
@KasraRahjerdi Showoff –  AsheeshR Dec 31 '13 at 15:55
    
@KasraRahjerdi Thanks for checking into it! I had my suspicions that my shoddy network connection was an issue. In fact, I get very unpredictable and inconsistent ("crashy") behavior most of the time (because of my network issues). Should I make a Meta post about that? –  jadarnel27 Dec 31 '13 at 16:05
    
@jadarnel27 Yes! That'd be wonderful, we don't do lots of stress-testing for bad conditions at the moment (which we should be doing). –  Kasra Rahjerdi Dec 31 '13 at 16:08
1  
Cool, @Kasra. I will write something up to complain about stuff and accuse you of things. –  jadarnel27 Dec 31 '13 at 16:14

1 Answer 1

I haven't been able to repro this on my own even after simulating a 4.1.2 phone running on very lossy EDGE and 3G connections, but I'm made what seems to be causing the crash from the report log be thread-safe. I'd be very interested in seeing if this still happens for you as of version 0.1.80 coming out sometime around midnight UTC.

share|improve this answer
    
@AsheeshR the app is set to be installable on SD card, but if I remember correctly by default most phones install to internal and then let you later move apps to the SD card. –  Kasra Rahjerdi Jan 1 at 1:41
    
@AsheeshR I just released 0.1.80 about 20 minutes ago, it'll take 2-3 hours to come out onto the Play store. –  Kasra Rahjerdi Jan 1 at 2:08
1  
@AsheeshR according to my crash log the one you got upon opening the app is the one I think I fixed in 0.1.80 :) –  Kasra Rahjerdi Jan 1 at 2:11
    
Yep I get an automated crash report for everything! The issue is a race-condition so I wouldn't be shocked if it didn't show up one way but showed up another but was still the same root cause. –  Kasra Rahjerdi Jan 1 at 3:39
    
@AsheeshR if a full uninstall of the app doesn't fix it, let me know and we can pop in a chat whenever you have time in the next few days to figure out what's going on. –  Kasra Rahjerdi Jan 1 at 5:59
    
@jadarnel27 Got the crash report, I'm still trying to figure out how to get a repro of this on my side so I can actually fix it. I'll hopefully update this answer relatively soon. –  Kasra Rahjerdi Jan 3 at 1:52
    
@KasraRahjerdi The app finally installed and is working! :) The app still keeps crashing on tapping the "show more comments" option. However, there is a slight delay (~1 second) between tapping and the crash, during which all comments are visible (not sure if that helps). –  AsheeshR Jan 8 at 17:27
    
@AsheeshR yay! I think the crash is a race condition, I can't quite nail why the loading of comments starts it though. –  Kasra Rahjerdi Jan 8 at 17:36
    
I've repeated the problem on 0.1.84, although it is less frequent! I was able to load several question-comment threads before I experienced a crash (on this question, actually). Then the app crashed twice while I was trying to leave this comment here (eventually just went to desktop to do that). –  jadarnel27 Jan 13 at 5:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .