What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

Is anybody else having problems with http://stackoverflow.com/ when browsing the site through Linux Google Chrome?

It appears that some (most?) JavaScript driven buttons do not work.

Examples:

  • Incorrectly reports that the email address is invalid
  • Upvote button has no effect
  • Favorite button has no effect.
share|improve this question
    
Like... what? Can you bring more details to the table? –  random Sep 22 '09 at 15:41
    
Like trying to upvote a question: pressing the button has no effect. –  jldupont Sep 22 '09 at 15:42
    
Have cleared your cache? –  random Sep 22 '09 at 15:44
    
I am puzzled now... clearing the cache solved the problem... care to explain? –  jldupont Sep 22 '09 at 15:49
    
Jean-Lou: Don't celebrate too soon... I wouldn't be surprised to hear that it's only a temporary effect. If not though, I'll certainly be clearing my cache tomorrow :) –  Jon Skeet Sep 22 '09 at 16:26
1  
If it's the same problem as I've been seeing, other symptoms include a lack of answer preview and a lack of editing toolbar, with shortcut keys failing too. –  Jon Skeet Sep 22 '09 at 16:27
    
Linux Chrome or Chromium? I'm not sure how big the difference is, but there are some. –  Macha Sep 22 '09 at 19:02
    
Indeed, I have the same problem with a completely new Google Chrome (so it cannot be a cache issue) meta.stackexchange.com/questions/35075/… –  bortzmeyer Jan 10 '10 at 17:46
    
Try to disable: "Enable Experimental JavaScript" by going to chrome://flags/ –  kenorb Jul 31 '12 at 15:15

2 Answers 2

up vote 2 down vote accepted

Every now and then the team will release some changes and fixes to the code. That includes tweaking of the JavaScript.

If you find the site not responding to your will, say when you vote or any other interaction with the site that involves JavaScript, it's a good idea to clear your cache to see if that solves the problem.

Your machine would have been running a cached version of the JavaScript that might not be as fresh as the new site release would work with. Or referencing something else.

share|improve this answer
2  
So you guys (i.e. SO) aren't using ETAG then? –  jldupont Sep 22 '09 at 16:16
2  
note that all changes have a revision number appended to the javascript, like so: file.js?v=1234 so if true, some caching proxy is ignoring querystrings. –  Jeff Atwood Sep 23 '09 at 2:27

I've had problems today and yesterday, yes. (I believe there was a new drop over the weekend... or it may just have been that that's when our desktop updater picked it up.) I don't know whether the version I use is exactly the same as the version you're using (I don't know whether internally we're ahead of the public "dev" channel or behind it; I suspect we're on it) but it sounds like the same problem.

I've found that restarting Chrome solves the issue temporarily, but that it becomes problematic again fairly soon. I've switched to Firefox for SO (and related sites) temporarily; hopefully it'll be fixed in the next version. (If it isn't, I'll try to delve a bit deeper and work out what's going wrong.)

Until now, it's been working very well - I'm looking forward to normal service resuming :)

share|improve this answer
    
Wouldn't the issue be dampened through the use of ETAG HTTP header? –  jldupont Sep 22 '09 at 16:38
    
Without knowing what the issue really is, I couldn't say. –  Jon Skeet Sep 22 '09 at 17:21
    
@jon: Of course. I am assuming they have a 'refresh problem' (as hinted by @random) in which case they might be using the "expires" HTTP header instead of ETAG. –  jldupont Sep 22 '09 at 17:46
    
I'm not at all sure that's the problem... but we'll see. –  Jon Skeet Sep 22 '09 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .