What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

Let's say I want to tag a question "sql-server-2008" on stack overflow.

There are 823 questions tagged Sql-server-2008 but, the tag matching engine won't find it even if I type in:

Sql-server-200

Why does the tag matching algorithm hide this tag? I guess it's because there's another tag starting with the same string and with a higher count, but still, I think this could use some tweaking ...

share|improve this question
    
What browser are you using? –  random Sep 25 '09 at 11:16
    
Reproducible with Firefox 3.5.3 and Opera 10. With IE 7 the issue shows up slightly different, but is still there (After sql-server- 2008 tag is available but no sql-server-2008- tags). –  Ladybug Killer Sep 25 '09 at 11:45
    
I'm using Firefox 3.5.3 –  Brann Sep 25 '09 at 14:41

2 Answers 2

up vote 0 down vote accepted

cannot reproduce, either on the \tags page or the \ask page.

I get the expected partial matches when I type "sql-server-200" (without the quotes) in either box.

EDIT: apparently we neglected to turn off caching for the autocomplete plugin. Should be fixed now.

share|improve this answer
    
I've just reproduced it at home (on stackoverflow.com/questions/ask) : "sql-server-200" (without quotes) returns me a single match (ie sql-server-2005). I'm using Firefox 3.5.3 aswell –  Brann Sep 26 '09 at 9:33
    
no repro, see screenshot –  Jeff Atwood Sep 26 '09 at 22:15
    
it works (and my comment is long enough)! –  Brann Sep 28 '09 at 17:02

I can reproduce this on the ask page using FF3.5.3.

alt text

Interestingly, if I go back to the start of the string and delete the initial 's', the expected matches come up.

alt text

share|improve this answer
    
ok, but how? I can't repro it. Typing speed? mouse vs keyboard? No idea. –  Jeff Atwood Sep 26 '09 at 23:58
    
Just using keyboard, typing speed doesn't seem to make any difference. If you type the entire name of a tag, the autocomplete can find it, and if you delete the initial portion, it will match on the middle part of the string, e.g. l-server-200 works just fine. Also, if you provide sql-server-2008, then it finds that tag and sql-server-2008-express and sql-server-2008-r2 as well. Let me know if there's any more detail I can provide. –  ベレアー アダム Sep 27 '09 at 1:52
    
Still can't repro, firefox 3.5.3 –  Jeff Atwood Sep 27 '09 at 16:10
    
Have you cleared your browser cache? Maybe your js or ajax response is cached. –  ベレアー アダム Sep 27 '09 at 17:13
1  
ok, we neglected to turn off caching for the autocomplete plugin. should be fixed now. –  Jeff Atwood Sep 28 '09 at 8:11
    
Confirmed fixed. :) –  ベレアー アダム Sep 28 '09 at 12:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .