What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I currently have my Stack Exchange android app settings as show below. Basically just the status bar notification since vibrate and sound are turned off.

However, on at least 3 occasions in the past few days I have received a vibrate notification (the most recent being right now while I'm writing this bug report).

enter image description here

Detailed behaviour

  • If phones master behaviour is set to sound & vibrate - in app setting are followed (correct behaviour)
  • If phone is set to vibrate only - phone vibrates irrespective of the current settings
  • If phone is set to mute - everything is off (correct behaviour)

System

Phone: Samsung Galaxy S3
Android Version: 4.3
Stack Exchange App version: 1.0.43

share|improve this question
    
Any chance that changing your phone's notification volume settings helps? (Easily accessible by touching the Gear icon next to the volume slider that is shown when using the hardware volume rocker.) –  Arjan Jun 30 at 17:04
    
@Arjan Previously everything but media was at mute, now everything is as you describe. Would the phone volume affect the vibration though? –  Richard Tingle Jun 30 at 17:06
    
I'm not using the app, so can't check. I'd except the top-bar notifications to use the 3rd setting though. But now I see it's actually disabled... –  Arjan Jun 30 at 17:07
    
...also: the screenshot from my previous comment is different from the settings I see after touching the Gear icon. But: both are disabled. –  Arjan Jun 30 at 17:08
    
@Arjan The app uses its own settings for vibration. I believe it does use the third setting for the volume of the notification, but of course I have (successfully) silenced that within the app –  Richard Tingle Jun 30 at 17:09
    
I'm not sure, but I'd expect my phone to vibrate for top-bar notifications, if that 3rd setting for the phone menu were enabled. (Regardless any additional vibration setting in any app.) –  Arjan Jun 30 at 17:11
    
@Arjan But in that case what is the purpose of the in-app option? –  Richard Tingle Jun 30 at 17:12
    
...maybe to vibrate when you don't have vibration enabled for all notifications...? (I don't know! Also, see the screenshots I added to my previous comment -- the Sound settings seem to indicate notifications are disabled altogether, but the quick settings seem to indicate vibration. Both settings cannot be changed though, as I set my phone to vibrate. Quite confusing...) –  Arjan Jun 30 at 17:16
    
@Arjan This is interesting, I unmuted my phone (but left notifications on silent) and that last message from you did not trigger a vibrate. Could you message me one more time for a final test –  Richard Tingle Jun 30 at 17:18
1  
@Arjan Ok, I've got the behaviour sorted out (edited) you're right; when the phone is set to vibrate only the settings are ignored, when the phone is set to sound and vibrate the settings are followed –  Richard Tingle Jun 30 at 17:23
1  
Has anyone been able to repro this on a non Samsung device? I'm going to try to see if it happens on my S3 in the office tomorrow. –  Kasra Rahjerdi Jul 1 at 22:03

1 Answer 1

up vote 3 down vote accepted

Update:

This is fixed for version 1.0.44 coming out soon, we have lots of changes in the pipeline so it might be a little bit slower of a release than normal.

It looks like this has been an issue with Samsung devices from 4.1 and above, that if your notification attempts to make any sound while the phone is in vibrate mode the notification will cause the device to vibrate rather than ignore the sound. This happens even when you've explicitly said "Please don't vibrate for this notification", which is hilarious.

Here's the code difference for anyone that wants it, note that before this bug the if statement was only the first line :)

    // If vibrations are disabled or we're in quiet hours, don't vibrate
    if(inQuietHours || !defaultPrefs.getBoolean("pref_notif_vibrate", true)) {
        notif.defaults &= ~Notification.DEFAULT_VIBRATE;

        // On some devices (Samsung ones as far as I can tell) attempting to make any sound while
        // in RINGER_MODE_VIBRATE will vibrate, even if you've told the notification not to vibrate.
        // On normal devices, the sound would be ignored, but not in this case. So, just to be safe,
        // let's never send in a sound if: 1. The device is in vibrate mode. 2. We've been told to not vibrate.
        // see http://meta.stackexchange.com/q/234851/229741 for our bug, https://code.google.com/p/android/issues/detail?id=39918
        // for android bug explaining that sound == vibration in this mode.
        AudioManager am = (AudioManager)context.getSystemService(Context.AUDIO_SERVICE);
        if (am.getRingerMode() == AudioManager.RINGER_MODE_VIBRATE) {
            notif.defaults = 0;
            notif.sound = null;
            notif.vibrate = null;
        }
    }

Repro'd on my S3 by having vibration disabled in our app, and the phone on vibrate (hit the volume button to the last option, so the "Silent" icon is shown in the status bar, but the notification tray says "Vibrate" is on). This doesn't happen when the phone's volume is set higher. My S3 is running Android 4.3 too, and is model SPH-L710.

Investigating further...

share|improve this answer
    
Thanks for sorting this. I have no idea why samsung have made this change –  Richard Tingle Jul 2 at 16:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .