Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 155 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I am unable to submit questions and answers from Android App version 1.0.43 running on Android 4.3 (Samsung Galaxy SIII)

  • My StackOverflow reputation at the time of this posting is only 16 if that has any impact.
  • My Meta.StackExchange reputation at the time of this posting is only 1, again, if that has any impact.

I can post questions and answers from my PC.

My experience with asking a question is:

  • I choose a site (Meta Stack Exchange)
  • Type a Subject
  • Compose question (> 160 characters)
  • Choose a tag (android-app)
  • Hit Preview - All displays well.
  • Hit SUBMIT - The SUBMIT button changes to orange for the duration of the press, but nothing else happens.
  • Hit the cross in the top left corner and the question closes.
  • Go to create a new question, and I get a dialog asking if I want to resume or discard a draft. Clicking resume displays my un-posted question.

My experience with submitting an answer is:

  • Click "View 0 Answers"
  • Click "Add an answer"
  • I compose my answer.
  • I press "Preview" - Nothing appears to happen. No spinning wheel, nothing. (Actually, the preview button changes to orange from blue).
  • I press "Submit" and the same result, except the submit button changes colour.

No question or answer is posted to the site.

share|improve this question
    
Thanks for the report! You should at the very least be getting a error message, I'm sorry for the bad state. I'll take a look ASAP. – Kasra Rahjerdi Aug 8 '14 at 3:20
1  
I've had 20 minutes spare time, so I installed a logcat, and attempt to reproduce my error to add some info. My post was successful, so I can't provide a logcat :-( I hope a change was made at the back end, cause the only difference is that the post that worked was sent on a 3g network the failed one was on a wifi connection. I will test again when i get wifi. – I.T. Navigate Aug 8 '14 at 7:25
    
I think one letter is missing: "Samsun" – A.L Aug 8 '14 at 10:22
    
@A.L edited thanks. – I.T. Navigate Aug 8 '14 at 10:51
    
@I.T.Navigate let me know if it happens again on WiFi, I looked at all your API calls and none of them had any bad state (but granted we don't save POST data so all I could see is that a 200 was returned), I'm going to take a look at if we're just not displaying error messages in the app correctly, in case the API was returning something valuable. – Kasra Rahjerdi Aug 8 '14 at 17:41
    
@KasraRahjerdi is there a sandbox i can test posting, or shall I test by answering this question? I got in trouble with my last test as it actually worked and threatened with account deletion. – I.T. Navigate Aug 13 '14 at 4:16
    
@I.T.Navigate Yes, but it might overload your phone: meta.stackexchange.com/questions/3122/formatting-sandbox – Kasra Rahjerdi Aug 13 '14 at 4:17
    
@KasraRahjerdi Can't find the answer button :-( – I.T. Navigate Aug 13 '14 at 4:22
    
@I.T.Navigate Yeah I figured, that post is our worst-case scenario in-app. Try posting an answer on here, then deleting it if it works. – Kasra Rahjerdi Aug 13 '14 at 4:23
    
@KasraRahjerdi That worked, but how fo i delete it? I did get an auto update today. – I.T. Navigate Aug 13 '14 at 4:25
    
@I.T.Navigate Hit the three dots next to it's timestamp and hit "Delete". I wonder what was causing this then... – Kasra Rahjerdi Aug 13 '14 at 4:26
    
@KasraRahjerdi Create another sandbox for the app, maybe? – user259867 Aug 13 '14 at 4:27
    
@KasraRahjerdi I only have share edit and flag. – I.T. Navigate Aug 13 '14 at 4:28
    
@I.T.Navigate Another bug! I deleted it :) – Kasra Rahjerdi Aug 13 '14 at 4:28
1  
@KasraRahjerdi Ta. It's not a bug, it's a feature. :-) – I.T. Navigate Aug 13 '14 at 4:30

You must log in to answer this question.

Browse other questions tagged .