Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I suppose this isn't so much of a bug as an annoyance. Yesterday afternoon I checked my email and had a "1 question has 1 answer on ServerFault" email. I got excited (too excited probably), in hopes of having gotten a good answer. When I opened the email, though, the answer was one I had posted to my own question. I understand that answering your own question is likely a rare occurrence, but notification shouldn't be sent in that case. After all, the asker knows s/he answered the question, no?

share|improve this question

Did you answer under a different account? Maybe you could provide a link to the question in question, perchance??

edit:

here's the only account I could find for you:

http://serverfault.com/users/9735

maybe this question?

http://serverfault.com/questions/26837/splunk-form-search-with-multiple-variables

share|improve this answer
    
Yeah Jeff, it was the splunk search question. Also, I do only have 1 account. – thepocketwade Jul 5 '09 at 22:12
    
Jeff, I have just seen the same behaviour with a question I asked on Super User. Strangely(?) the e-mail was not sent until nearly 2 days after I answered. – Dan Dyer Sep 25 '09 at 11:35

I know that this doesn't raise a notification on your own recent activity page. I have never had a chance to actually see if that is the case using the email notifications. If so that would be interesting.

share|improve this answer

This also happened to me on StackOverflow when I answered my own question here:

Can I specify a range with the IntegerValidator attribute on a custom ConfigurationSection?

The email basically contains my own answer to this question, presumably because I've not yet marked it as accepted - I guess I should have turned off alerts for that question, but I wanted to leave it open for a while to see if anyone had any better ideas.

I don't have enough rep to edit the question to mark this as a bug ;)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .