Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

Hi,

I have a keyboard issue with the '}' key. At the moment, I have to actually copy/paste this character whenever I want to use it inside a 'question' or 'answer' WYSIWYG editor on this website. If I type it using my keyboard it is replaced automatically by

enter your code here

if I am at the beginning of a line or by

`enter your code here`

if I am not.

I am using an AZERTY keyboard (being French).

On an azerty keyboard, the '}' character is two keys to the right of the '0' character and requires the 'ALT-GR' key (right of the space key) to be pressed for activation, I was wondering if this could be misinterpreted by the editor.

It does make typing code bothersome, especially since I am mostly a C++ user!

EDIT: Following an answer: Yes I use Firefox 3.5 on Windows XP.

I'd rather not change my language though, I prefer my keys to actually reflect the characters they will produce.

For any idea or suggestion...

share|improve this question
    
FYI: once configured, toggling between keyboard layouts involves pressing Left Alt + Shift. Still an annoyance, I admit, but perhaps more convenient than some other options. – McDowell Oct 27 '09 at 16:08
    
Issue has been fixed, though whether because of a change in stack overflow or Firefox I have no idea... it's great though! – Matthieu M. Oct 9 '10 at 11:05

Using a UK keyboard map, I see the same behaviour (Alt Gr+=), but only with Firefox on Windows (Chrome on Windows, IE and Firefox on Ubuntu do not respond to the key-combination).

You might want to confirm your OS, browser, versions and so on if you want a fix.

As a temporary workaround, you can try switching browsers and/or making use of your operating system's input services to remap the keyboard (for example, Windows lets you switch language input at will via a taskbar icon).

share|improve this answer

There must be a conflict between your '}' key and the shortcut assigned to "code sample" (ctrl-k).

I can only say that while I also have an AZERTY keyboard (being Belgian), I don't have this issue. Granted, my '}' sign is on the '0' key, not two keys right of it, but I also have to use the 'ALT-GR' key to type it.

share|improve this answer

This issue is now fixed, but before I was using [ALT + 125] to write a '}' character...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .