Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

When using the auto-complete on careers.stackoverflow.com, only the characters I type are stored and displayed on saved document--not what the autocomplete seems to complete. Fields effected:

  • University
  • Other: First Computer
  • Other: Favorite Editor

Probably others too. Details:

FF 3.5.3
OSX 10.6.1
share|improve this question
    
+1 I saw this in the University field. – Matthew Jones Oct 7 '09 at 21:34
1  
I had this happen to me as well, my favorite editor was ne. – James McMahon Oct 12 '09 at 17:53
    
@James McMahon, to be fair, ne is quite a nice editor anyway. – SpoonMeiser Nov 2 '09 at 15:41
up vote 2 down vote accepted

I've seen this too, and I think I've figured out why.

The careers site appears to save fields as part of a blur event on the field.

What I imagine happens, is this:

  • you type the first however many characters
  • autocomplete dropdown appears
  • you click the autocomplete dropdown
  • blur event triggers on the input field, the content of the input field gets saved
  • the content of the input field gets replaced from autocomplete.

Since another blur event doesn't get triggered on the field, the autocomplete data doesn't get saved.

The work-around seems to be not to use the mouse the select options from the autocomplete dropdown.

share|improve this answer
    
Nice investigative work - thank you :) – Jarrod Dixon Nov 13 '09 at 9:20

Quick fix was to have text inputs retain focus after the autocomplete selection; not the best solution, but it'll fire that blur again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .