Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

On , I click on "file CV", and Firefox gives me this error: uses an invalid security certificate.
The certificate is not trusted because the issuer certificate is unknown.
(Error code: sec_error_unknown_issuer)

Of course, I could be the subject of a man-in-the-middle attack, but I suspect there is a more prosaic cause!


I'm seeing Comodo as the issuer, but Firefox is still saying: "the certificate is not trusted because the issuer certificate is unknown."

It works OK in IE7.

Would it help if I post more details of the cert I'm seeing?


It's working OK now.

thanks, Geoff :)

share|improve this question
The issuer is Stack Overflow? – Ladybug Killer Oct 28 '09 at 11:36
I get the same error – Oskar Oct 28 '09 at 11:37
No-repo for me. (Using FF 3.0.14 on Ubuntu 9.04.) – Stephan202 Oct 28 '09 at 11:48

We have installed Comodo root and intermediate certificates - could somebody having this issue please verify if this has resolved the issue.

UPDATE Received five new certificates from COMODO our SSL Provider, installed all of them including Trusted Root Certification and Intermediate Certification Authorities

Installing these required a server reboot. It should be working now.

share|improve this answer
I'm still seeing the error. :( – AJ. Oct 28 '09 at 16:26
I get the error when using Firefox on Windows. IE 8 gives me no errors. – Chris C Oct 28 '09 at 17:26
Roger that, ChrisC. IE 7 gives me no errors, either. – AJ. Oct 28 '09 at 17:31

This is a good site to make sure the cert and chain is installed correctly -

And I have had problems with Firefox caching an invalid certificate which makes it real difficult to troubleshoot these problems.

share|improve this answer

I got this yesterday, too. It appears to be fixed now.

SO team probably left the self-signed test cert on it by accident.

share|improve this answer
still not working for me - possibly some caching going on (??). I'll try again tomorrow. thanks :) – AJ. Oct 28 '09 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .