What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

This is a demonstration of a post that does not render properly (the lack of hyperlink):


code
code
code
text text [logging module][1] (http://docs.python.org/library/logging.html). more text.
...stuff
share|improve this question

3 Answers 3

up vote 1 down vote accepted

From this:

[logging module][1] (http://docs.python.org/library/logging.html)

You'll want to drop that [1] and go with this:

[logging module](http://docs.python.org/library/logging.html)

To get this:

logging module

share|improve this answer
    
That's a red herring. –  Ether Nov 20 '09 at 2:12

This looks like markdown doesn't want to parse links in a block immediately preceding a section surrounded by <pre> tags. Your [foo][1] label with footnote looks fine, and inserting one with the hyperlink WYSIWYG tool generates the same format (which also doesn't work).

I noticed you used <code> and <pre> tags -- it's generally easier to just indent your text by four spaces (which the binary button at the top of the editing window will do for you).


text using code and pre tags
Here is a [link][1] that does not work... through experimentation, it would seem that it is the <pre> tag following that screws things up.
...stuff inside a pre tag
text using four spaces of indentation

Here is a link that does work.

share|improve this answer
    
"Doctor, it hurts when I do this!" –  Jeff Atwood Nov 20 '09 at 18:18
    
@Jeff: so you're saying that <pre> and <code> tags are invalid markdown syntax? That was not at all clear... –  Ether Nov 20 '09 at 18:46

From what I see of your raw post text, you have not used valid Markdown.

Please refer to the editing help, which is linked:

  • in the little [?] icon above the edit area
  • in the sidebar under full reference »
share|improve this answer
    
Incorrect. See my post for another reproduction of this issue. –  Ether Nov 20 '09 at 18:15
    
it is in fact correct; indent 4 spaces instead of hard coding <pre><code> -- problem solved. –  Jeff Atwood Nov 20 '09 at 18:17
    
But all I did was select the text and use the "add link" feature, I didn't write this markdown syntax myself so how can it be my fault? –  plafayette Dec 7 '09 at 2:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .