Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

Every once in a while my attempt to edit a question fails. I make an edit, click the "Save Your Edits" button, the button becomes disabled, but the refresh of the page never happens and the edits don't take.

For instance, I can't edit this question. I've tried several times over the last couple days, so it's not just a one-time glitch. Anyone else have a problem editing it? If not, why can't I?

Per John's comment, I tried clearing the cache in Firefox 3.5.5 and I tried it in IE8. Still no go.

Okay, I understand what's going on. Jeff's answer, and Diago's comment to that answer, helped me see the light.

  • I was not aware that the minimum title length was raised from 10 to 15. This explains how a question with a title under the limit came to exist, yet could not be edited.
  • I'm so used to seeing only the edit button, I forgot there is a retag button if you don't have enough rep to edit. Since there is no validation of the question during a simple retag operation, this explains how John was able to retag it.

To those voting to close this as "exact duplicate": Please leave a link to the question of which this is a dupe. I would like to see it and will gladly vote to delete this question if it is the same.

share|improve this question
Which browser, which version? Have you cleared your cache? – Ladybug Killer Nov 21 '09 at 18:45
Confirmed, Safari 4.0.3 (6531.9) and Firefox 3.5.5 on Mac – luvieere Nov 21 '09 at 19:39
I cannot either. – GManNickG Nov 21 '09 at 19:49
Sadly I have no editing powers, but I retagged it successfully with FireFox 3.5.5 (I hate these beolongs-to tags anyway). I've found nothing special at that question. – Ladybug Killer Nov 21 '09 at 20:03
Can't edit with Firefox 3.5.5 on windows vista - got the same results as OP. – Amarghosh Nov 21 '09 at 22:05
I cannot edit it either (with the same symtoms as the OP). In case it's relevant, at the moment the question has 4 close votes on it. – Ether Nov 21 '09 at 22:28
Try it in Opera, you might never go back. – random Nov 21 '09 at 23:02
I had the same problem yesterday in IE7 for one question. I don't remember what it was, though, so I can't test it in Firefox. – mmyers Nov 22 '09 at 5:39
@raven: With your rep, I thought you are able to see the close reasons for your own question. Sorry, if I'm wrong:… – Ladybug Killer Nov 24 '09 at 8:19
@John: I'm not following you. I can see why people have voted to close this question. That's why I asked for a link to the duplicate to which they are referring. The question you linked to in your comment was asked after mine, so shouldn't it be closed as the dupe? – raven Nov 24 '09 at 13:25
@raven: Oops, you're right, my bad! The other should be closed. - So you are seeing the close reasons, but not the link to the dupe? – Ladybug Killer Nov 24 '09 at 21:09
@John: correct. – raven Nov 24 '09 at 22:35
up vote 4 down vote accepted

This might actually be the title length problem again.

memory problem

Yep, make sure the title is at least 15 characters.

edit: We moved most of the post validation to the server, which helps reduce any client JavaScript quirks that would prevent submission. This also means submission errors can be simplified and placed in the same area on the form:

share|improve this answer
Explains why I couldn't edit the SO Clones question a few weeks back, never got a chance to look into it. – BinaryMisfit Nov 23 '09 at 16:45
How is it that John Smithers was able to edit the question while I was not? He didn't actually edit the question proper (he doesn't have the rep), rather just the tags, but I was not able to even do that. Hmm, let me guess. You don't bother validating the question if it's being edited by someone who can only edit the tags? – raven Nov 23 '09 at 17:19
@raven. You don't need to edit the question to edit tags. On the question view you can choose to retag which only edits the tags and nothing else without entering the full edit page. Just hover your mouse next to the empty space next to the tags – BinaryMisfit Nov 23 '09 at 17:28
@Diago: I don't see anything when I hover my mouse next to the empty space next to the tags. However, I do see the "retag" link under other people's questions here on meta where I don't have enough rep to edit. I'm so used to just seeing the edit link on SO. I think I've got this all figured out now. – raven Nov 23 '09 at 18:45
Maybe the minimum length should be reduced to 12 or something, it seems most legit titles that don't make it only miss it by a character or two. – GManNickG Nov 23 '09 at 18:47
I agree with raven; once I have editing privileges the option to simply retag seems to be gone - one must enter full editing mode to change the tags. (I would love to see the 'retag' link return; sometimes I only need to do a simple retagging and it seems to be faster to load the page as well.) – Ether Nov 23 '09 at 19:35
If the question is 'invalid' it shouldn't be possible to submit it to begin with. Validate on creation as well as edit. – Ether Nov 23 '09 at 19:35
@Diago that's moderator only functionality – Jeff Atwood Nov 24 '09 at 3:40
@Jeff. That explains it. I often forget that. – BinaryMisfit Dec 2 '09 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .