What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 129 Stack Exchange communities.

The search box in the top right of the sites has a white background explicitly declared. If you are using a dark theme for your OS, the default text colour is often white or near white, making it appear as if the search box is not working. Could you fix this?

Possible fix:

Add a color:black declaration for the CSS of #hsearch .textbox.

Also: The Tags box tends to flash white while loading the suggestions.

PICTURES:

Text in, but not shown

Highlighted (this would look the same if color:black was applied aswell):

Here

EDIT: The box to type in your openID while logging in is also affected.

share|improve this question
    
Pictures added. There isn't much to see. –  Macha Dec 19 '09 at 16:23
    
Heh... So it's letting the system text color come through, but overriding the background color? Oops... –  Shog9 Dec 19 '09 at 17:11
    
@Shog9: Yes. It's not alone in this at least. Pidgin does the opposite (overrides the text color, and allows the background through). –  Macha Dec 19 '09 at 20:28
    
This problem was among the many reasons I de-themed my browser when I was running a dark theme. –  Paul McMillan Dec 27 '09 at 19:01
    
I have the opposite situation: black text on black background. But I have a different suggestion. Instead of setting the colours, just don't set them to anything. This works well with the default settings, but if you set only one, then, obviously, it doesn't. At the very least it could be made an option in account settings... not a huge thing to ask, I suppose. –  user202917 Nov 25 '12 at 14:44
    
@wvxvw Confirming this - have same problem. –  Ivan Kolmycheck Jul 2 '13 at 18:57

You must log in to answer this question.

Browse other questions tagged .