What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

The "Add Comment" button on SO has started appearing to the right of the comment text input box. This makes it get covered up by the text for adverts et al. Can we have it appearing under the comment input, please.

http://kwout.com/cutout/8/xc/9c/36t_bor.jpg

John's suggestion of using non-text zoom has improved things. However, I still get this strange display when I edit a comment:

http://kwout.com/cutout/6/qe/zq/s2u_bor.jpg

share|improve this question
5  
I think a screenshot with freehand circles is needed. Otherwise you're going to hear the programmer's lament - "It works for me!" –  ChrisF Dec 27 '09 at 19:03
    
The lack of freehand circles offends my eyes! –  Ladybug Killer Dec 27 '09 at 19:42
    
Not reproducible. Hit CTRL+F5. If it still occurs: Browser, version, OS? –  Ladybug Killer Dec 27 '09 at 19:48
    
Firefox 3.5.6, Win2K SP4. –  nb69307 Dec 27 '09 at 19:53
    
Win2K? Ouch! I had several issues on my old laptop with Win2K and (older) Firefox versions, which weren't reproducible with WinXP. The OS could be the culprit here (or the incompatibility of FF with this OS). –  Ladybug Killer Dec 27 '09 at 19:58
1  
Well, I've been using SO for 10 months now on the same machine & OS and this problem seems to have started today. I suspect there has been a code change. And Win2K is certainly much more reliable & performant than some of the recent bloatware issuing from Redmond. –  nb69307 Dec 27 '09 at 20:05
    
Yes, there was a change. You can edit comments now (for the first 5 minutes). That's why I suggested CTRL+F5. Maybe you should consider clearing your cache, too. Have you tried Safe mode? –  Ladybug Killer Dec 27 '09 at 20:08
    
Neither Ctrl-F5 nor clearing the cache have any effect. –  nb69307 Dec 27 '09 at 20:13
    
Safe Mode neither? Extensions like Firebug can cause a lot of trouble. –  Ladybug Killer Dec 27 '09 at 20:16
    
No, safe mode makes no difference. and I don't use too many addons - just AdBlock, NoScript and a status bar enhancement. –  nb69307 Dec 27 '09 at 20:21
    
Does this appear always, or only with some special questions? –  Ladybug Killer Dec 27 '09 at 20:23
    
Always, and not just on SO, but om Meta too. –  nb69307 Dec 27 '09 at 20:24
    
Do you see the edit link somewhere to edit your comment? It should be next to the time stamp ("1 min ago edit") –  Ladybug Killer Dec 27 '09 at 20:28
    
Yep, I get that. If I hit it though I end up with a rather strange display with two edit inputs and two buttons.The top one is labelled "Save Your Edit" and the bottom one, who's edit contains no text, has a button labelled "Add Comment" –  nb69307 Dec 27 '09 at 20:31
    
Strange? Shoot it! –  Ladybug Killer Dec 27 '09 at 20:34
show 4 more comments

4 Answers 4

up vote 0 down vote accepted

Your strange display is normal. It just shows the comment edit box and the box to enter a complete new comment.

It looks different from my previous shot, because your comment is the last one, just above the "add comment" box. In my shot it was a comment between two other comments.

share|improve this answer
    
Rather strange GUI design, IMHO - but thanks v. much for your help. –  nb69307 Dec 27 '09 at 21:32
    
You're always welcome! –  Ladybug Killer Dec 27 '09 at 21:34
add comment

I have this strange problem, also. Recommendation: put the button and links below the box. It will work every time. Sometimes life is just easier if you agree with the Muses. I've wasted an hour too much on this problem.

See question 39570

share|improve this answer
add comment

I have on many occasions found that this sort of error was because of PeerBlock, ProtoWall, or an ad-blocker blocking an external CSS or JS file.

Disable AdBlock, NoScript, etc. Those very addons (ie ad blockers) are exactly the ones that cause this sort of behavior on web pages. Turn off all extensions as well as external security things like IP blockers, etc. and see if it works. Then you can go through the process of figuring out which blocking app is the one that is causing it and which IP/site/file/etc. is being blocked, then create an exception for it.

share|improve this answer
    
As I said in my comment, I get the same problem in safe mode, where those addons are not loaded. –  nb69307 Dec 27 '09 at 20:40
    
I thought you meant Windows safe mode (I haven’t used FireFox in a long time). Anyway, it could still have been an external ad/ip blocker or something blocking a CSS or JS file. –  Synetech Dec 28 '09 at 20:16
add comment

alt text

share|improve this answer
    
OK, that is more or less what I am getting (I still get the extra edit below it however). But I use a fairly large font size (I'm getting old) and this is pushing the button into the right-hand text. This seems simply like poor design - if the button was positioned UNDER the edit, there woould be less of a problem. This is on a 17 inch 1280 x 1024 screen, BTW, so it's not like I'm trying to scrunch things into a tiny display. –  nb69307 Dec 27 '09 at 20:47
    
You are using large font size? Aaahhh! Why didn't you mention that from the beginning? Use the zoom function of the browser instead. It scales better than just increasing your font. –  Ladybug Killer Dec 27 '09 at 20:52
    
Zoom is what I do use - same problem. –  nb69307 Dec 27 '09 at 20:53
    
There is a difference between "font only zoom" and "zoom". Always zoom the whole page, not only the fonts. "View"->"Zoom"->"Zoom Text only" must not be checked! –  Ladybug Killer Dec 27 '09 at 21:02
    
That does improve things - thanks! I still get the strange "two edits" behaviour - will try and post a shot of that, to prove I'm not hallicinating. –  nb69307 Dec 27 '09 at 21:07
add comment

You must log in to answer this question.