What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

When trying to submit a comment to http://stackoverflow.com/questions/2077736/how-to-present-geographical-and-other-data-on-the-web, an iframe is shown below the comment box, containing "Oops, something bad has happened" and http://sstatic.net/so/img/error-lolcat-problemz.jpg .

The user agent is accurate, i.e. Firefox 3.5 on Linux. Same problem with Opera 10.10 on Linux.

A split second later, the whole page becomes blank.

Partial dump:

POST /posts/2077750/comments HTTP/1.1
Host: stackoverflow.com
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.6 (like Firefox/3.5.6; Debian-3.5.6-1)
Accept: text/html, */*
Accept-Language: en,de-de;q=0.8,en-us;q=0.5,de;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
X-Requested-With: XMLHttpRequest
Content-Length: 243
Cookie: [removed]
Pragma: no-cache
Cache-Control: no-cache
comment=%40jcd+Exactly+what+I'm+looking+for%2C+but+I+need+additional+functionaly+like+sorting%2C+grouping%2C+and+a+map%2Fgraph+interface.+The+table+is+about+1000x20%2C+so+I+can't+present+it+in+raw+form.%0A&fkey=[removed]

Answer:

HTTP/1.1 302 Found
Cache-Control: private
Content-Type: text/html; charset=utf-8
Location: /error?aspxerrorpath=/posts/2077750/comments
Server: Microsoft-IIS/7.0
Date: Sat, 16 Jan 2010 15:29:48 GMT
Content-Length: 173


<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="%2ferror%3faspxerrorpath%3d%2fposts%2f2077750%2fcomments">here</a>.</h2>
</body></html>

Next request:

GET /error?aspxerrorpath=/posts/2077750/comments HTTP/1.1
Host: stackoverflow.com
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6) Gecko/20091216 Iceweasel/3.5.6 (like Firefox/3.5.6; Debian-3.5.6-1)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en,de-de;q=0.8,en-us;q=0.5,de;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
[more headers and gzipped answer removed]
share|improve this question
1  
+1 for all the debugging work. :) –  Kip Jan 16 '10 at 21:52

1 Answer 1

up vote 2 down vote accepted

Yep, bug in handling users with blank usernames when you try to @username reply to them in a comment.

Eg "unknown (yahoo)" -- this isn't an actual username, the username is null for this user, so that string is derived from their OpenID.

These anonymous users are now ignored for the purposes of comment replies, so @unknown won't work -- there's no actual user name to match against.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .